又是一篇题解:Longest Ordered Subsequence

给定一个数字序列,需要找出其最长的有序子序列并输出该子序列的长度。题目提供了一个样例输入序列(1, 7, 3, 5, 9, 4, 8),最长有序子序列的长度为4。程序需要处理1到1000个元素且数值范围在0到10000之间的序列。" 138487431,8451564,使用kubeadm搭建多master Kubernetes高可用集群实践,"['kubernetes', '集群部署', '高可用', '网络组件', '故障恢复']

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

关于动态规划的题解


写了一个01背包,而这个题却不是01背包…

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8
Sample Output
4


题意(翻译)
如果a1<a2<…<aN。设给定数字序列(a1,a2,…,aN)的子序列是任意序列(ai1,ai2,…,aiK),其中1<=i1<i2<。。。<iK<=N。例如,序列(1,7,3,5,9,4,8)具有有序的子序列,例如,(1,7),(3,4,8)和许多其他序列。所有最长有序子序列的长度都是4,例如(1,3,5,8)。
当给定数字序列时,程序必须找到其最长有序子序列的长度。
输入:
输入文件的第一行包含序列N的长度,第二行包含序列N整数的元素,每个元素的范围从0到10000,用空格隔开。1<=N<=1000
输出:
输出文件必须包含一个整数-给定序列的最长有序子序列的长度。

这个就是找子序列的问题,找到最长有序子序列,输出最长有序子序列的长度。

#include<cstdio>
#include<iostream>
#include<algorithm>

using namespace std;
int main() {
	int n, a, cnt;
	int ans[1005] = {0};
	while(cin >> n) {
		cnt = 0;
		while(n--) {
			cin >> a;
			if(cnt == 0)
				ans[cnt++] = a;
			else {
				if(a > ans[cnt-1]) {
					ans[cnt++] = a;
				} else {
					int pos = lower_bound(ans, ans+cnt-1, a)-ans;
					ans[pos] = a;
				}
			}
		}
		cout << cnt << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值