Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
题目大意:
求在目标串中能找到多少模式串,串可以重叠。
这题只要把kmp函数修改一下就行,匹配成功就使ans++并用next数组回跳到下一个匹配位置,直到目标串指针指到末尾。
AC代码:
kmp:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char s[1000005];
char p[10005];
int nex[10005];
void cal_next(int lenp, int lens){
nex[1] = 0;
int j;
for (int i = 2; i <= lenp; i ++){
j = nex[i - 1];
while(j > 0 && (j == lens || p[i] != p[j + 1]))j = nex[j];
if (p[i] == p[j + 1]) j ++;
nex[i] = j;
}
}
int kmp(int lenp, int lens){
int ans = 0;
int i = 1, j = 1;
while(j <= lens){
if (p[i] == s[j])i ++, j ++;
else if(i > 1)i = nex[i - 1] + 1;
else j ++;
if (i > lenp)ans ++, i = nex[i - 1] + 1;
}
return ans;
}
int main()
{
int t;
cin >> t;
while(t --){
scanf("%s", p + 1);
scanf("%s", s + 1);
int lenp = strlen(p + 1);
int lens = strlen(s + 1);
cal_next(lenp, lens);
cout << kmp(lenp, lens) << endl;
}
return 0;
}
hash:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
typedef unsigned long long ull;
const int N = 1e6 + 5;
char a[10005];
char b[1000005];
ull f[N], p[N];
int main()
{
int t;
cin >> t;
while(t --){
scanf("%s", a);
scanf("%s", b + 1);
int lena = strlen(a);
int lenb = strlen(b + 1);
p[0] = 1;
for (int i = 1; i <= lenb; i ++){
f[i] = f[i - 1] * 131 + b[i] - 'a' + 1;
p[i] = 131 * p[i - 1];
}
ull ha = 0;
for (int i = 0; i < lena; i ++)ha = ha * 131 + a[i] - 'a' + 1;
int cnt = 0;
//cout << ha << endl;
for (int i = 1; i + lena - 1 <= lenb; i ++){
int j = i + lena - 1;
//cout << f[j] - f[i - 1] * p[j - i + 1] << endl;
if(f[j] - f[i - 1] * p[j - i + 1] == ha)cnt ++;
}
cout << cnt << endl;
}
return 0;
}