Baby Ming and Weight lifting
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1344 Accepted Submission(s): 491
Problem Description
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively
a
and
b
), the amount of each one being infinite.
Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted C (the barbell must be balanced), he want to know how to do it.
Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted C (the barbell must be balanced), he want to know how to do it.

Input
In the first line contains a single positive integer
T
, indicating number of test case.
For each test case:
There are three positive integer a,b , and C .
1≤T≤1000,0<a,b,C≤1000,a≠b
For each test case:
There are three positive integer a,b , and C .
1≤T≤1000,0<a,b,C≤1000,a≠b
Output
For each test case, if the barbell weighted
C
can’t be made up, print Impossible.
Otherwise, print two numbers to indicating the numbers of a and b barbell disks are needed. (If there are more than one answer, print the answer with minimum a+b )
Otherwise, print two numbers to indicating the numbers of a and b barbell disks are needed. (If there are more than one answer, print the answer with minimum a+b )
Sample Input
2 1 2 6 1 4 5
Sample Output
2 2 Impossible
Source
Recommend
直接枚举就行了,如果总重量为奇数,就直接输出impossible,如果是偶数,先判断能不能直接构成,然后枚举,0ms过的,但是枚举的情况比较多,附代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int i,j,k,l,m,n,p,x,y,z,ans1,ans2;
int main()
{
scanf("%d",&p);
while(p--)
{
scanf("%d%d%d",&x,&y,&z);
if(z%2)
{
printf("Impossible\n");
continue;
}
else
{
int help=max(x,y);//最大的
int cnt=min(x,y);//最小的
if(help*2>z)//如果不要最大的
{
if(z%cnt!=0)//然后总重量除以最小的除不尽
printf("Impossible\n");//那么肯定不能
else
{
if((z/cnt)%2==0)//如果不要最大的,单是最小的能构成,并且个数为偶数个
{
if(x==cnt)
printf("%d 0\n",z/cnt);//那么输出就行了
else
printf("0 %d\n",z/cnt);
}
else//如果只由最小的构成,单是个数为奇数,肯定不能行
printf("Impossible\n");
}
}
else
{
int flag=0;
for(i=z/help;i>=0;i--)//因为要求输出的和最小,所以需要把最大的用最多个
{
if(flag)//标记打破循环
break;
if((z-i*help)%cnt==0)//如果能满足当前个数的最大的,能和若干个最小的构成
{
if(flag)
break;
int cmt=(z-i*help)/cnt;//就逐个判断
for(j=i;j>=0;j--)
{
if(flag)
break;
for(k=0;k<=cmt;k++)
{
if(k*cnt+j*help==z/2)//如果能构成一半
{
//printf("%d %d\n",i,cmt);
ans1=i;//就得到了结果
ans2=cmt;
flag=1;
}
}
}
}
}
if(flag)
{
if(x==help)
printf("%d %d\n",ans1,ans2);
else
printf("%d %d\n",ans2,ans1);
}
if(flag==0)
printf("Impossible\n");
}
}
}
}