hdoj 5610 Baby Ming and Weight lifting 【暴力】【水题】

本题涉及BabyMing使用两种不同重量的杠铃盘实现特定总重量的平衡杠铃的问题。需要通过算法找出最少数量的杠铃盘组合以达到目标重量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Baby Ming and Weight lifting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 727    Accepted Submission(s): 296



Problem Description
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively a  and  b ), the amount of each one being infinite.

Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted  C (the barbell must be balanced), he want to know how to do it.

 

Input
In the first line contains a single positive integer  T , indicating number of test case.

For each test case:

There are three positive integer  a,b , and  C .

1T1000,0<a,b,C1000,ab
 

Output
For each test case, if the barbell weighted  C  can’t be made up, print Impossible.

Otherwise, print two numbers to indicating the numbers of  a  and  b  barbell disks are needed. (If there are more than one answer, print the answer with minimum  a+b )
 

Sample Input
  
  
2 1 2 6 1 4 5
 

Sample Output
  
  
2 2 Impossible
 

Source
 

由于杠铃要两边平衡,所以C是奇数的时候直接impossible~

AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
int main()
{
	int T; Si(T);
	Wi(T)
	{
		int a, b, c;
		scanf("%d%d%d", &a, &b, &c);
		if(c%2){
			printf("Impossible\n");
			continue;
		}
		else
		{
			int i, j;
			int ans = INF;
			int x, y;
			bool flag = 0;
			for(i = 0; i <= c/a; i++)
			{
				for(j = 0; j <= (c-a*i)/b; j++)
				{
					if(i*a+j*b == c/2)
					{
						flag = 1;
						if(ans > i+j )
						{
							ans = i+j;
							x = i, y = j;
						}	
					}
				}
			}
			if(!flag)  printf("Impossible\n");
			else	printf("%d %d\n", 2*x, 2*y);
		}
	}
	return 0;
} 



内容概要:本文详细介绍了基于FPGA的144输出通道可切换电压源系统的设计与实现,涵盖系统总体架构、FPGA硬件设计、上位机软件设计以及系统集成方案。系统由上位机控制软件(PC端)、FPGA控制核心和高压输出模块(144通道)三部分组成。FPGA硬件设计部分详细描述了Verilog代码实现,包括PWM生成模块、UART通信模块和温度监控模块。硬件设计说明中提及了FPGA选型、PWM生成方式、通信接口、高压输出模块和保护电路的设计要点。上位机软件采用Python编写,实现了设备连接、命令发送、序列控制等功能,并提供了一个图形用户界面(GUI)用于方便的操作和配置。 适合人群:具备一定硬件设计和编程基础的电子工程师、FPGA开发者及科研人员。 使用场景及目标:①适用于需要精确控制多通道电压输出的实验环境或工业应用场景;②帮助用户理解和掌握FPGA在复杂控制系统中的应用,包括PWM控制、UART通信及多通道信号处理;③为研究人员提供一个可扩展的平台,用于测试和验证不同的电压源控制算法和策略。 阅读建议:由于涉及硬件和软件两方面的内容,建议读者先熟悉FPGA基础知识和Verilog语言,同时具备一定的Python编程经验。在阅读过程中,应结合硬件电路图和代码注释,逐步理解系统的各个组成部分及其相互关系。此外,实际动手搭建和调试该系统将有助于加深对整个设计的理解。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值