CET-6 test
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 569 Accepted Submission(s): 415
Problem Description
Small W will take part in CET-6 test which will be held on December
20th
. In order to pass it he must remember a lot of words.
He remembers the words according to Ebbinghaus memory curve method.
He separates the words into many lists. Every day he picks up a new list, and in the next 1st,2nd,4th,7th,15th day, he reviews this list.
So every day he has many lists to review. However he is so busy, he does not know which list should be reviewed in a certain day. Now he invites you to write a program to tell him which list should to be reviewed in a certain day.
Lists are numbered from 1. For example list 1 should be reviewed in the 2nd,3rd,5th,8th,16th day.
He remembers the words according to Ebbinghaus memory curve method.
He separates the words into many lists. Every day he picks up a new list, and in the next 1st,2nd,4th,7th,15th day, he reviews this list.
So every day he has many lists to review. However he is so busy, he does not know which list should be reviewed in a certain day. Now he invites you to write a program to tell him which list should to be reviewed in a certain day.
Lists are numbered from 1. For example list 1 should be reviewed in the 2nd,3rd,5th,8th,16th day.
Input
Multi test cases (about 100), every case contains an integer n in a single line.
Please process to the end of file.
[Technical Specification]
2≤n≤100000
Please process to the end of file.
[Technical Specification]
2≤n≤100000
Output
For each n,output the list which should be reviewed in the
nth
day in ascending order.
Sample Input
2 100
Sample Output
1 85 93 96 98 99
Source
Recommend
.....
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;
int main()
{
while(scanf("%d",&n)!=EOF)
{
if(n>15)
printf("%d ",n-15);
if(n>7)
printf("%d ",n-7);
if(n>4)
printf("%d ",n-4);
if(n>2)
printf("%d ",n-2);
printf("%d\n",n-1);
}
}