L1-064 估值一亿的AI核心代码 (20 分)

这篇博客介绍了一个用C++编写的AI英文问答程序,该程序根据用户输入进行特定的文本处理,如删除多余空格、大小写转换、特定词汇替换等。博主分享了详细的代码实现过程,虽然没有使用正则表达式,但通过逐个字符检查和字符串操作实现了功能。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

团体程序设计天梯赛-练习集
L1-064 估值一亿的AI核心代码 (20 分)

在这里插入图片描述

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。
输入格式:
输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:
按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:
6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
输出样例:
Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don’t know

如果你会正则表达式,这个题对于你来说很简单。可惜,我不会,只能一点一点的写了。

#include <iostream>
#include <string>
#include <cstring>
#include <cctype>

using namespace std;

int judge(char c) {
    if(c>'0' && c<'9') return 1;
    else if(c>='a' && c<='z') return 2;
    else if(c>='A' && c<='Z') return 3;
    else if(c==' ') return 4;
    else return 5;
}
string Deal(string str) {
    //去除行首的括号。行末
    while (str[0] == ' ') str.erase(0, 1);
    while(str[str.size()-1]==' ') str.erase(str.size()-1,1);
    //去除标点符号前面,以及连续出现的空格, ispunct()函数,判断是否为标点
    for (int i = 0; i < str.size();) {
        if (str[i] == ' ' && (ispunct(int(str[i + 1])) || str[i + 1] == ' ')) {
            str.erase(i, 1);
        }
        else i++;
    }

    //?变换为!
    while (str.find('?') != string::npos) str[str.find('?')] = '!';
    
    //大小写转换    
    for (int i = 0; i < str.size(); i++) {
        if (str[i] >= 'A' && str[i] <= 'Z' && str[i] != 'I') str[i] = str[i] + 32;
    }
     
    //先把 can you, could you 变成 ? can,? could
    //因为这个时候句子里不可能有?等把 I 和 me 替换完之后,直接把?变成 I 即可
    if(str.find("can you ") == 0) str.replace(0,8,"? can ");
    for(int i=1;i<str.size();){
        if(str[i-1] == ' ' && str[i]=='c' && str.substr(i,7)=="can you"){ 
              if(judge(str[i+7]) != 2 && judge(str[i+7])!=3) str.replace(i,7,"? can");  
        }
        else i++;
    }
  
    if(str.find("could you ") == 0) str.replace(0,10,"? could ");
    for(int i=1;i<str.size();){
        if(str[i-1] == ' ' && str[i]=='c' && str.substr(i,9)=="could you"){ 
              if(judge(str[i+9]) != 2 && judge(str[i+9])!=3) str.replace(i,9,"? could");  
        }
        else i++;
    }    
    //把 I,me 进行转换

    if (str[0] == 'I' && str[1] == ' ') str.replace(0, 1, "you");
    if( str[str.size()-1] =='I' && str[str.size()-2] == ' ') str.replace(str.size()-1, 1, "you");
    for (int i = 1; i < str.size();) {
        if (str[i-1] ==' '&&str[i] == 'I' && (ispunct(int(str[i + 1])) || str[i + 1] == ' ')) {
            str.replace(i,1,"you");
        }
        else i++;
    }
   
    if(str.find("me ") == 0) str.replace(0,3,"you ");
     while (str.find("me") != string::npos && !isalpha(str[str.find("me") - 1]) && !isalnum(str[str.find("me") +2])) {
        str.replace(str.find("me"), 2, "you");
    }

    //再把?换回成 I
    while (str.find("?") != string::npos) str.replace(str.find("?"), 1, "I");

    return str;
}

int main() {
    int n;
    cin >> n;
    cin.get();
    string str;
    for (int i = 0; i < n; i++) {
        getline(cin, str);
        cout << str << endl;
        Deal(str);
        cout << "AI: " << Deal(str) << endl;
    }
}

写的也是比较复杂,但是起码过了

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值