An easy problem
Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
Give you a letter x and a number y , you should output the result of y+f(x).
Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
Output
for each case, you should the result of y+f(x) on a line.
Sample Input
6 R 1 P 2 G 3 r 1 p 2 g 3
Sample Output
19 18 10 -17 -14 -4
#include<stdio.h>
int main()
{
int n,x,i;
char str;
scanf("%d",&n);
getchar(); //注意
while(n--)
{
scanf("%c%d",&str,&x);
getchar();
if(str>='a'&&str<='z')
printf("%d\n",'a'-str+x-1);
else if(str>='A'&&str<='Z')
printf("%d\n",str-'A'+x+1);
}
return 0;
}