PAT典型题目(8)贪心

通过给定的一组数字片段,找到能组合成的最小数字。例如,给定{32, 321, 3214, 0229, 87},最小数字可能是0229-321-3214-32-87。程序通过排序和拼接实现数字恢复,并移除前导零。" 121070176,11101954,MySQL数据库操作详解,"['数据库', 'SQL', 'MySQL', '数据查询']

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1038. Recover the Smallest Number (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:
5 32 321 3214 0229 87
Sample Output:

22932132143287

#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
using namespace std;
const int maxn=10010;
string str[maxn];
bool cmp(string a,string b){
    return a+b<b+a;
}
int main(){
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        cin>>str[i];
    }
    sort(str,str+n,cmp);
    string ans;
    for(int i=0;i<n;i++){
        ans+=str[i];
    }
    while(ans.size()!=0&&ans[0]=='0'){
        ans.erase(ans.begin());
    }
    if(ans.size()==0) cout<<0;
    else cout<<ans;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值