Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

#include <stdio.h>
#include <iostream>
#include <queue>
#include <string.h>
using namespace std;
const int N=2e3+5;
const int INF = (int) 0x3f3f3f3f;
int n, m; 
int mp[N][N]; 
void init(int n){
	for(int i = 0; i < n; i++){
		for(int j = 0; j < n; j++){
			if(i == j) mp[i][j] = 0;
			else mp[i][j] = mp[j][i] = INF; 
		}
	}
}
void getmap(int m){
	int u, v, val;
	while(m--){
		scanf("%d%d%d", &u, &v, &val);
		u--; v--;
		mp[u][v] = mp[v][u] = min(mp[u][v], val);
	}
}
bool vis[N]; int dis[N];
void djk(int st, int ed){ 
	for(int i = 0; i < n; i++){
		vis[i] = false;
		dis[i] = mp[st][i];
	} 
	vis[st] = true;
	for(int i = 1; i < n; i++){
		int mn = INF, id = -1; 
		for(int j = 0; j < n; j++){
			if(!vis[j] && dis[j] < mn) {
				mn = dis[j]; id = j;
			}
		}
		if(id == -1) break;
		vis[id] = true;
		for(int j = 0; j < n; j++){
			if(!vis[j] && mp[id][j] != INF) { 
				if(dis[j] > dis[id] + mp[id][j]) 
					dis[j] = dis[id] + mp[id][j];
			}
		}
	}
	printf("%d\n", (dis[ed] == INF) ? -1 : dis[ed]);
}
int main(){
	while(cin>>m>>n){
		init(n);
		getmap(m);
		djk(n - 1, 0);
	}
	return 0;
}

 

内容概要:本文详细介绍了CCF-GESP认证的学习资源与知识点指南,分为官方资源与平台、知识点学习与解析、备考策略与工具、实战项目与进阶资源以及学习工具推荐五个部分。官方资源包括CCF数字图书馆提供的免费真题库、一站式学习平台和GESP官网的最新真题下载及考试环境说明。知识点学习部分涵盖Python、C++和图形化编程(Scratch)的核心内容与实战案例。备考策略方面,提出了基础、强化和冲刺三个阶段的分阶段计划,并强调了在线题库模拟测试与社区交流的重要性。实战项目与进阶资源则为不同编程语言提供了具体的应用场景,如Python的智能客服机器人和C++的并行编程与嵌入式开发。最后,推荐了多种学习工具,如代码编辑器VS Code、模拟考试平台和社区支持渠道。 适合人群:准备参加CCF-GESP认证考试的考生,特别是对Python、C++或Scratch编程语言有兴趣的学习者。 使用场景及目标:①帮助考生系统化地学习官方资源,熟悉考试形式和内容;②通过分阶段的备考策略,提高应试能力和编程技能;③利用实战项目和进阶资源,增强实际编程经验和解决复杂问题的能力。 阅读建议:建议考生按照文章中的分阶段备考策略逐步推进学习进度,充分利用官方提供的资源进行练习和模拟测试,并积极参与社区交流以获取更多备考经验和疑难解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值