HDOJ 题目1394 Minimum Inversion Number(数状数组求逆序对)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11721    Accepted Submission(s): 7184


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1698  1540  1542  1255  1754 
 ac代码
#include<stdio.h>
#include<string.h>
int num[10010],a[10010],n;
int low(int x)
{
	return x&(-x);
}
void updata(int p,int q)
{
	while(p<=n)
	{
		a[p]+=q;
		p+=low(p);
	}
}
int sum(int p)
{
	int ans=0;
	while(p>0)
	{
		ans+=a[p];
		p-=low(p);
	}
	return ans;
}
int main()
{
	//int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		__int64 min,ans=0;
		memset(a,0,sizeof(a));
		for(i=1;i<=n;i++)
		{
			scanf("%d",&num[i]);
			updata(num[i]+1,1);
			ans+=i-sum(num[i]+1);
		}
		min=ans;
		for(i=1;i<=n;i++)
		{
			ans+=n-2*num[i]-1;
			if(min>ans)
				min=ans;
		}
		printf("%I64d\n",min);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值