1002 A+B for Polynomials

本文详细介绍了一种解决多项式加法问题的算法,通过数组模拟实现两个多项式的相加,输入包含两个多项式的系数和指数,输出为相加后的多项式表达式,精确到小数点后一位。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

数组模拟一下就好了

#include<bits/stdc++.h>
using namespace std;

#define ee exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

const int maxn=1111;
double p[maxn];

int main()
{
	
	int k,n;
	double a;
	scanf("%d",&k);
	for(int i=0; i<k; i++)
	{
		scanf("%d%lf",&n,&a);
		p[n]=a;
	
	}
	scanf("%d",&k);
	for(int i=0; i<k; i++)
	{
		scanf("%d%lf",&n,&a);
		p[n]+=a;
		
	}
	
	
	int cnt=0;
	for(int i=0; i<maxn; i++)
	{
		if(p[i]!=0)cnt++;
	}
	printf("%d",cnt);
	for(int i=maxn-1; i>=0; i--)
	{
		if(p[i]!=0)printf(" %d %.1f",i,p[i]);
	}
	puts("");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值