Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
#include <cstdio>
int main(){
int a,b,c;
scanf("%d%d",&a,&b);
c=a+b;
if(c<0){
printf("-");
c=-c;
}
int num[10],len=0;
do{
num[len++]=c%10;
c/=10;
}while(c);
for(int i=len-1;i>=0;i--){
printf("%d",num[i]);
if(i%3==0&&i!=0)
printf(",");
}
}