PAT甲级 1160 Forever

PAT甲级 1160 Forever

题目

“Forever number” is a positive integer A with K digits, satisfying the following constrains:

    the sum of all the digits of A is m;
    the sum of all the digits of A+1 is n; and
    the greatest common divisor of m and n is a prime number which is greater than 2.

Now you are supposed to find these forever numbers.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤5). Then N lines follow, each gives a pair of K (3<K<10) and m (1<m<90), of which the meanings are given in the problem description.

Output Specification:

For each pair of K and m, first print in a line Case X, where X is the case index (starts from 1). Then print n and A in the following line. The numbers must be separated by a space. If the solution is not unique, output in the ascending order of n. If still not unique, output in the ascending order of A. If there is no solution, output No Solution.

Sample Input:

2
6 45
7 80

Sample Output:

Case 1
10 189999
10 279999
10 369999
10 459999
10 549999
10 639999
10 729999
10 819999
10 909999
Case 2
No Solution

题解

#include <bits/stdc++.h>

bool isPrime(int num) {
    if(num <= 2) return false;
    for(int i = 2; i * i <= num; i++) {
        if(num % i == 0) return false;
    }
    return true;
}

int digitSum(long long n) {
    int result = 0;
    while (n) {
        result += n % 10;
        n /= 10;
    }
    return result;
}

std::vector<std::pair<int, long long>> findNumber(int K, int m) {
    std::vector<std::pair<int, long long>> result;
    long long start = std::pow(10, K - 1) + 9;
    long long end = std::pow(10, K);
    for(long long i = start; i < end; i += 10) {
        if(digitSum(i) == m && isPrime(std::gcd(m, digitSum(i + 1))))
            result.emplace_back(digitSum(i + 1), i);
    }
    std::sort(result.begin(), result.end()), [](std::pair<int, long long> a, std::pair<int, long long> b) {
        if(a.first != b.first) return a.first < b.first;
        return a.second < b.second;
    };
    return result;
}

int main() {
    std::ios::sync_with_stdio(false);
    std::cin.tie(nullptr);

    int N, K, m;
    std::cin >> N;
    for(int i = 1; i <= N; i++) {
        std::cin >> K >> m;
        std::cout << "Case " << i << std::endl;
        std::vector<std::pair<int, long long>> result = findNumber(K, m);
        if(result.empty()) std::cout << "No Solution" << std::endl;
        else
            for(const auto& p : result)
                std::cout << p.first << " " << p.second << std::endl;
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

polarours

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值