Poj-2318-TOYS

本文深入探讨了游戏开发领域的核心技术,包括游戏引擎、动画、3D空间视频等,旨在为开发者提供全面的游戏开发知识和实践经验。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 

 

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.


Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10

0


Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1


0: 2
1: 2
2: 2
3: 2

4: 2


Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

这道题的大概意思是先输入6个数字:n,m,x1,y1,x2,y2。n代表卡片的数量,卡片竖直(或倾斜)放置在盒内,可把盒子分为n+1块区域,然后分别用0到n表示,m代表玩具的个数,(x1,y1)代表盒子的左上顶点坐标,(x2,y2)代表盒子的右下顶点坐标,接下来的n行,每行都有两个数a,b,(a,y1),(b,y2)分别代表卡片的两个顶点位置,接下来的m行每行两个数从c,d,(c,d),代表玩具放置的坐标,最后让你输出每个区域内的玩具有多少个,输入第一个数为0时结束。

简化一下就是给你一个长方形平面左上顶点和右下顶点的坐标,然后有n条线,将长方形分成n+1块,然后给你m个点的坐标,问你每个区域有几个点。

思路:这是一道简单的计算几何题,只要想到用叉乘判断点是否在区域内就可以了。

叉乘的性质: 若向量P,Q

P*Q<0;  则Q在P的右边;

P*Q=0;则Q与P平行或重合

P*Q>0;则Q在P的左边

因为此题中玩具的点已经可以确定在另外三边中,即左边,上边,下边,所以只需判断是否在由卡片组成的边左边即可,我们对每一个点都从第一条边判断开始,直到找到其所属区域,然后计数,输出

代码如下:

#include <algorithm>
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
struct note{
    int x1;
    int x2;
};
struct note a[5005];
int c[5005];
//叉乘计算
int chacheng(int b1,int b2,int b3,int b4)
{
    int s=b1*b4-b2*b3;
    if(s>0)
        return 1;
    else
        return 0;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n!=0)
    {
        memset(c,0,sizeof(c));
        int m,x1,y1,x2,y2,i,j;
        scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);
        for(int i=1;i<=n;i++)
            scanf("%d %d",&a[i].x1,&a[i].x2);
        //将长方形的右边作为最后一条边
        a[n+1].x1=x2;
        a[n+1].x2=x2;
        for(i=0;i<m;i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            for(j=1;j<=n+1;j++)
            {
                //判断此点是否在当前边的左边
                int c1;
                c1=chacheng(a[j].x1-a[j].x2,y1-y2,x-a[j].x2,y-y2);
                if(c1==1)
                {
                    c[j-1]++;
                    break;
                }
            }
        }
        for(i=0;i<=n;i++)
            printf("%d: %d\n",i,c[i]);
        printf("\n");
    }
    return 0;
}

内容概要:本文详细介绍了PMSM(永磁同步电机)的仿真研究及其两种关键控制方法:三电平SVPWM矢量控制和双环矢量控制。首先阐述了PMSM在现代电机驱动系统中的重要地位及其广泛的应用领域,如电动汽车、机器人和风力发电等。接着讨论了PMSM仿真的重要性,包括电气特性、机械特性和热特性等方面的考量。然后深入探讨了三电平SVPWM矢量控制技术的工作原理及其对电机性能的提升效果,如提高运行效率和减少谐波失真。随后介绍了PMSM双环矢量控制的具体实现方式,即内环电流控制和外环速度控制相结合的方法,强调了这种方法在提高电机动态性能和稳定性方面的优势。最后对比了传统三电平控制方法和双环矢量控制方法的特点,指出了各自的优势和应用场景。 适合人群:从事电机控制系统研究的技术人员、高校相关专业师生、对电机控制感兴趣的工程技术人员。 使用场景及目标:适用于需要深入了解PMSM控制技术和仿真实现的研究项目和技术开发。目标是帮助读者掌握PMSM的仿真建模方法,理解并应用三电平SVPWM和双环矢量控制技术,以优化电机性能。 其他说明:本文不仅提供了理论分析,还通过MATLAB进行了详细的仿真演示,使读者能够直观地看到不同控制方法的效果。这对于实际工程项目的设计和优化具有重要的指导意义。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值