HDU 1035 Robot Motion

Robot Motion
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10221 Accepted: 4978

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source

由于边线没处理好 WA了一次才AC  ...........
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int i,j,n,m,k;
char a[100][100];
int b[100][100];
int c[100][100];
void f()
{
    char kk;
    int p = 0,q = k-1,h = 1,t = 0;
    kk = a[p][q];
    b[p][q] = 1;
    while(h != 0)
    {
        if(kk == 'N')
        {
            p = p - 1;
            if(b[p][q] == 1)
            {
                printf("%d step(s) before a loop of %d step(s)\n",c[p][q],t-c[p][q]+1);
                break;
            }
            b[p][q] = 1;
            t++;
            c[p][q] = t;
            if(p<0)
            {
                printf("%d step(s) to exit\n",t);
                h = 0;
                break;
            }
            kk = a[p][q];
        }
        else if(kk =='W')
        {
            q = q - 1;
            if(b[p][q] == 1)
            {
                printf("%d step(s) before a loop of %d step(s)\n",c[p][q],t-c[p][q]+1);
                break;
            }
            b[p][q] = 1;
            t++;
             c[p][q] = t;
            if(q<0)
            {
                printf("%d step(s) to exit\n",t);
                h = 0;
                break;
            }
            kk = a[p][q];
        }
        else if(kk == 'E')
        {
            q = q + 1;
            if(b[p][q] == 1)
            {
                printf("%d step(s) before a loop of %d step(s)\n",c[p][q],t-c[p][q]+1);
                break;
            }
            b[p][q] = 1;
            t++;
             c[p][q] = t;
            if(q>=m)
            {
                printf("%d step(s) to exit\n",t);
                h = 0;
                break;
            }
            kk = a[p][q];
        }
        else if(kk == 'S')
        {
            p = p + 1;
            if(b[p][q] == 1)
            {
                printf("%d step(s) before a loop of %d step(s)\n",c[p][q],t-c[p][q]+1);
                break;
            }
            b[p][q] = 1;
            t++;
             c[p][q] = t;
            if(p>=n)
            {
                printf("%d step(s) to exit\n",t);
                h = 0;
                break;
            }
            kk = a[p][q];
        }
    }
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        if(n==0 && m == 0 && k == 0)
        {
            break;
        }
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++)
        {
            scanf("%s",&a[i]);
        }
        f();
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值