Problem Description
好久不见牛郎哥哥了,织女非常想他,但是她想考验一下牛郎在她不在的日子里有没有好好学习天天向上,于是乎
想出一个问题考一考他。织女找了一跟很细的红线和N颗相同的钉子,将各颗钉子钉在墙上作为一个多边
形的各个顶点,然后将红线缠在各个钉子上围成了多边形,多余的剪掉。下面给出了图示。
可惜牛郎不会算,悲剧了,但他不想让织女失望,还好有你这个朋友,你的任务是帮他计算出红线的长度。
Input
在输入数据的第一行有两个数:N——钉子的数目(1 <= N <= 100),R——钉子的半径。所有的钉子半径
相同。接下来有N行数据,每行有两个空格隔开的实数代表钉子中心的坐标。坐标的绝对值不会超过
100。钉子的坐标从某一颗开始按照顺时针或逆时针的顺序给出。不同的钉子不会重合。
Output
输出一个实数(小数点后保留两位)————红线的长度。
Example Input
4 1
0.0 0.0
2.0 0.0
2.0 2.0
0.0 2.0
Example Output
Hint
import java.util.*;
class point {
double x;
double y;
public point(double x, double y) {
super();
this.x = x;
this.y = y;
}
public double getX() {
return x;
}
public void setX(double x) {
this.x = x;
}
public double getY() {
return y;
}
public void setY(double y) {
this.y = y;
}
public double length(point p) {
return Math.sqrt((x - p.x) * (x - p.x) + (y - p.y) * (y - p.y)); //本身自己的
}
}
public class Main {
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner cin = new Scanner(System.in);
int n = cin.nextInt();
int r = cin.nextInt();
point p[] = new point[100];
for (int i = 0; i < n; i++) {
double x = cin.nextDouble();
double y = cin.nextDouble();
p[i]=new point(x,y);
}
double sum=0;
for(int i=0;i<n-1;i++)
{
sum+=p[i].length(p[i+1]); //i+1<n i<n-1
}
sum+=p[n-1].length(p[0])+Math.PI*r*2; // 尾结点和头结点之间的距离
System.out.printf("%.2f\n",sum);
}
}