题目
Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.
Input Specification:
The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
Output Specification:
For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).
Sample Input:
3 1 2 3 2 3 4 9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false Case #2: true Case #3: false
需要考A+B虑溢出的问题,可能是上界,也可能是下界。
可以考虑string模拟大数的方法,代码用了一种适用于两个元素的投机方法。
代码:
#include <iostream>
using namespace std;
int main()
{
int n;
cin>>n;
long long a,b,c;
int i,j;
for(i=0;i<n;i++) //一种投机取巧的办法,仅适用于两个元素
{
cin>>a>>b>>c;
cout<<"Case #"<<i+1<<": ";
if(a>0&&b>0&&a+b<a&&a+b<b) //上越界,必然大于c
cout<<"true\n";
else if(a<0&&b<0&&a+b>a&&a+b>b) //下越界,必然小于c
cout<<"false\n";
else if(a+b>c) //常规比较
cout<<"true\n";
else
cout<<"false\n";
}
return 0;
}