PAT A 1064. Complete Binary Search Tree (30)

题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key. 
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key. 
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT.  You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case.  For each case, the first line contains a positive integer N (<=1000).  Then N distinct non-negative integer keys are given in the next line.  All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree.  All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

 

即根据输入构建完全二叉树,并按层序输出。

一棵深度为n的满的完全二叉树元素数量为2^n-1;

一棵深度为n+1的不满的完全二叉树,即为深度为n的满的完全二叉树再加上深度为n+1的元素;

底层元素中的前2^(n-1)个元素小于根,之后的大于根。

根据这个性质可以求出一个排序区间中根的编号。

 

代码:

#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>
using namespace std;

struct be	//探测结构,记录探测区域的起始点
{
	int begin;
	int end;
};

int Root(int p,int q);	//	求区域的根

int main()
{
	int n;
	vector<int> data;
	
	int i,temp;
	cin>>n;
	for(i=0;i<n;i++)
	{
		cin>>temp;
		data.push_back(temp);
	}
	sort(data.begin(),data.end());

	queue<be> level;
	int root;
	be tempbe1,tempbe2;
	tempbe1.begin=0;
	tempbe1.end=n-1;
	level.push(tempbe1);
	while(!level.empty())
	{
		tempbe1=level.front();
		level.pop();
		root=Root(tempbe1.begin,tempbe1.end);
		if(root-1>=tempbe1.begin)
		{
			tempbe2.begin=tempbe1.begin;
			tempbe2.end=root-1;
			level.push(tempbe2);
		}
		if(root+1<=tempbe1.end)
		{
			tempbe2.begin=root+1;
			tempbe2.end=tempbe1.end;
			level.push(tempbe2);
		}
		if(level.empty())
			cout<<data[root];
		else
			cout<<data[root]<<" ";
	}

	return 0;
}

int Root(int p,int q)	//求根
{
	if(p==q)
		return p;
	int d=q-p+1;	//区间元素数

	int temp=1;	
	while(temp<d)	//获取一个容得下所有元素的树填满的容量
	{
		temp++;
		temp*=2;
		temp--;
	}
	temp++;	//求除去底层叶子后的元素数量
	temp/=2;
	temp--;

	if(d-temp<=(temp+1)/2)	//底层元素数小于底层容量一半,即底层元素都小于根节点
		return p+d-temp-1+(temp+1)/2;
	else	//大于,则有一半比其小
		return p+temp;
}


 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值