题目
Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3 0 0 255 16777215 24 24 24 0 0 24 24 0 24 24 24
Sample Output:
24
即统计出现次数最多的数
代码:
#include <iostream>
#include <cstdio>
#include <map>
using namespace std;
int main()
{
int m,n; //输入数据
cin>>m>>n;
map<int,int> colour; //颜色,计数
int i,j,temp;
for(i=0;i<n;i++) //输入颜色
for(j=0;j<m;j++)
{
scanf("%d",&temp);
if(!colour[temp]) //颜色没有出现过
colour[temp]=1;
else //出现过
colour[temp]++;
}
map<int,int>::iterator p; //找最大并输出
int max_num=0;
int max_colour=0;
for(p=colour.begin();p!=colour.end();p++)
{
if((*p).second>max_num)
{
max_colour=(*p).first;
max_num=(*p).second;
}
}
cout<<max_colour;
return 0;
}