2017中国大学生程序设计竞赛 - 网络选拔赛 HDu CaoHaha's staff

本文介绍了一个魔法传送阵的数学模型,旨在最小化传送所需的时间。通过寻找接近菱形形状的传送阵来最大化面积,进而达到最优解。文章提供了一种算法实现方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

 

Problem Description

"You shall not pass!"
After shouted out that,the Force Staff appered in CaoHaha's hand.
As we all know,the Force Staff is a staff with infinity power.If you can use it skillful,it may help you to do whatever you want.
But now,his new owner,CaoHaha,is a sorcerers apprentice.He can only use that staff to send things to other place.
Today,Dreamwyy come to CaoHaha.Requesting him send a toy to his new girl friend.It was so far that Dreamwyy can only resort to CaoHaha.
The first step to send something is draw a Magic array on a Magic place.The magic place looks like a coordinate system,and each time you can draw a segments either on cell sides or on cell diagonals.In additional,you need 1 minutes to draw a segments.
If you want to send something ,you need to draw a Magic array which is not smaller than the that.You can make it any deformation,so what really matters is the size of the object.
CaoHaha want to help dreamwyy but his time is valuable(to learn to be just like you),so he want to draw least segments.However,because of his bad math,he needs your help.

 

 

Input

The first line contains one integer T(T<=300).The number of toys.
Then T lines each contains one intetger S.The size of the toy(N<=1e9).

 

 

Output

Out put T integer in each line ,the least time CaoHaha can send the toy.

 

 

Sample Input

 

5 1 2 3 4 5

 

 

Sample Output

 

4 4 6 6 7

 

 

 

思路:

菱形是为面积最大,尽量使图形靠近菱形。

 

代码:

 

 

#include<iostream>
#include<set>
using namespace std;

long long a[100000]={0}; 
// a[i] 表示边为 i 是最大能够围成的面积
int main ()
{
    long long T,i,j;
    for(i=4;i<=100000;i++)
        {
            int d,c;
            d=i/4;
            c=i/2-d;
            a[i]=d*c*2;
            if(i%2==1)
                a[i]+=(c-1);
        }
    cin>>T;
//    cout<<a[100000]<<endl;
    while(T--)
    {
         long long n;
         cin>>n;
         for(i=0;i<100000;i++)
         {
             if(a[i]>=n)
             {
                 cout<<i<<endl;
                 break;
            }
         }
    }
    return 0; 
}
 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值