题目描述:
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2<br>100<br>-4<br>
Sample Output
1.6152<br>No solution!<br>
Author
Redow
就是给你一个函数,把函数值给你,让你求出自变量的值。。
想法:
这个题函数是递增的,在(0,100)内 所以可以用二分查找 另精度问题可用<iomanip>头文件解决。。
代码:
#include <iostream>
#include<iomanip>#include <cmath>
using namespace std;
double v(double x)
{
return (8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6);
}
double f(double x,double z, double y)
{
double mid;
while((y-z)>1e-10)
{
mid=(z+y)/2;
if(v(mid)<x)
z=mid+1e-10;
else
y=mid-1e-10;
}
return mid;
}
int main()
{
int n;
double a;
cin>>n;
while(n--)
{
cin>>a;
if(a<6||a>807020306||fabs(f(a,0,100))<1e-4)
cout<<"No solution!"<<endl;
else
cout<<setprecision(4)<<fixed<<f(a,0,100)<<endl;
}
}
感想:
第一次用二分查找,感觉挺好用的。。