HDU 1068 Girls and Boys (二分最大独立集)

本文探讨了一种算法在分析大学学生浪漫关系网络中的应用,旨在找到最大的独立子集,即没有浪漫关系的学生群体。通过输入学生的浪漫关系描述,该算法能够输出满足条件的最大集合数量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9829    Accepted Submission(s): 4503


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2
 

Source
 

求一个集合中任意两个元素都无关系,即最大独立集
最大独立集=顶点数-最大匹配数
又因为这个二分图不知道哪个分在哪边,所以把所有顶点都遍历一下,最后把最大匹配数除以二

#include <iostream>
#include <cstring>
#define maxnum 555
using namespace std;

int vis[maxnum];
int link[maxnum];
int head[maxnum];
int cnt;

struct node
{
	int v;
	int next;
}list[maxnum*maxnum];

void init()
{
	cnt = 0;
	memset(head,-1,sizeof(head));
}

void add(int u,int v)
{
	list[cnt].v = v;
	list[cnt].next = head[u];
	head[u] = cnt++;
}

int find(int u)
{
	int i;
	for(i=head[u];~i;i=list[i].next)
	{
		int v = list[i].v;
		if(!vis[v])
		{
			vis[v] = 1;
			if(link[v] == -1 || find(link[v]))
			{
				link[v] = u;
				return 1;
			}
		}
	}
	return 0;
}

int match(int N)
{
	int i,sum=0;
	memset(link,-1,sizeof(link));

	for(i=0;i<N;i++)
	{
		memset(vis,0,sizeof(vis));
		if(find(i))
			sum++;
	}

	return sum;
}

int main()
{
	int i,j,k,kk;
	int a,b;
	int len;
	int u,v;
	int p,n,N;
	int flag;

	while(~scanf("%d",&N))
	{
		init();
		for(i=1;i<=N;i++)
		{
			scanf("%d: (%d)",&u,&k);
			for(j=1;j<=k;j++)
			{
				scanf("%d",&v);
				add(u,v);
			}
		}

		printf("%d\n",N-(match(N)>>1));
	}

	return 0;
}


**描述:“适用于JDK8的环境”** 本文将深入探讨Neo4j社区版3.5.6版本,这是一个基于图数据库的强大工具,特别适用于知识图谱构建和可视化。由于其运行需求,必须在Java Development Kit(JDK)8的环境下进行安装和操作。 **一、Neo4j概述** Neo4j是一款开源的图形数据库,它以节点、关系和属性的形式存储数据,这使得处理复杂网络结构的数据变得更为直观和高效。Neo4j社区版是免费的,适合开发和学习用途,而企业版则提供了更多的高级功能和服务。 **二、JDK8要求** 为了运行Neo4j 3.5.6,你需要在你的计算机上安装JDK8。JDK是Java开发工具包,包含了运行Java应用程序所需的Java虚拟机(JVM)以及一系列开发工具。确保安装的是与Neo4j版本兼容的JDK版本至关重要,因为不兼容的JDK可能会导致运行错误或性能问题。 **三、安装和配置** 1. **下载与解压**: 从官方渠道下载"neo4j-community-3.5.6.zip"压缩文件,并将其解压到你选择的目录。 2. **环境变量配置**: 配置系统环境变量,将Neo4j的bin目录添加到PATH环境变量中,以便于命令行启动和管理数据库。 3. **修改配置文件**: Neo4j的配置主要通过`conf/neo4j.conf`文件进行,如需更改默认设置,如内存分配、端口设置等,应在此文件中进行修改。 4. **启动和停止**: 使用`neo4j console`命令启动服务,`neo4j stop`命令关闭服务。 **四、知识图谱与可视化** Neo4j因其强大的图数据模型,成为构建知识图谱的理想选择。你可以使用Cypher查询语言来操作和查询图数据,它的语法简洁且直观,易于学习。 1. **Cypher语言**: Cypher是一种声明式、图形化
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值