hdu 5666

题意:给出一个线段x+y= b,然后和0坐标组成的三角形内有多少整数点;


思路: 1 + …… + (n - 2);等差数列求和(n-2)*(n - 1)/2;

运用大数相乘取模;


Segment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1911    Accepted Submission(s): 713


Problem Description
     Silen August does not like to talk with others.She like to find some interesting problems.

     Today she finds an interesting problem.She finds a segment  x+y=q .The segment intersect the axis and produce a delta.She links some line between  (0,0)  and the node on the segment whose coordinate are integers.

     Please calculate how many nodes are in the delta and not on the segments,output answer mod P.
 

Input
     First line has a number,T,means testcase number.

     Then,each line has two integers q,P.

    q  is a prime number,and  2q1018,1P1018,1T10.
 

Output
     Output 1 number to each testcase,answer mod P.
 

Sample Input
  
  
1 2 107
 

Sample Output
  
  
0
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

const int maxn = 100000 + 10;
//char ans[maxn];
ll mul(ll a,ll b,ll p)
{
	a %= p;
	b %= p; 
	ll ans = 0;
	ll t = a;
	while(b)
	{
		if(b & 1)
		{
			ans = (ans + t) % p;
		}
		b >>= 1;
		t = (t <<= 1) % p;
	}
	return ans;
}
ll n,p;
int main()
{
	int Tcase;
	scanf("%d",&Tcase);
	for(int ii = 1; ii <= Tcase; ii ++)
//	while( ~ scanf("%I64d%I64d",&n,&p))
	{
		scanf("%I64d%I64d",&n,&p);
		if(n < 0)
		n = -n;
		if(n - 2 < 1)
		{
			cout << 0 << endl;
			continue;
		}
		n -= 2;
		ll x,y;
		if((n + 1) % 2)
		{
			x = n / 2;
			y = (n + 1);
		}
		else 
		{
			x = (n + 1)/ 2;
			y = n;
		}
		cout << mul(x,y,p) << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值