Substrings hdu

                                          Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5336    Accepted Submission(s): 2371


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.


 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.


 

Output
There should be one line per test case containing the length of the largest string found.


 

Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid


 

Sample Output
  
  
2 2


 

Author
Asia 2002, Tehran (Iran), Preliminary


 

Recommend
Eddy

 

就是找最多的子串 正反都算

code:

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
	int cas;
	int n;
	string s[102];

	cin>>cas;
	int sub;
	int len;
	int maxn;
	int k;
	while(cas--)
	{
		cin>>n;
		len=999;
		sub=0;
		for(int i=0;i<n;i++)
		{
			cin>>s[i];	
			if(len>s[i].size())
			{
				len=s[i].size();
				sub=i;
			}			
		}
		maxn=0;
		for(int i=s[sub].size();i>0;i--)
		 for(int j=0;j<s[sub].size()-i+1;j++)
		 {
		 	string s1,s2;
 			s1=s[sub].substr(j,i);
 			s2=s1;
 			reverse(s2.begin(),s2.end());
 			for( k=0;k<n;k++)
 			{
			 	if(s[k].find(s1,0)==-1&&s[k].find(s2,0)==-1)
			 	break;
			 	
			 }
			 if(k==n&&maxn<s1.size())
			 maxn=s1.size();	 
 			
 		}
 		cout<<maxn<<endl;
	}
	return 0;
} 


 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值