Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample OutputCase 1: 14 1 4
Case 2: 7 1 6
import java.util.Scanner;
public class Main
{
public static int Max=100010;
public static long INF=1<<30;
public static void main(String[] args)
{
int T,n;
Scanner in=new Scanner(System.in);
T=in.nextInt();
long a[]=new long[Max];
for(int cas=1;cas<=T;cas++)
{
n=in.nextInt();
for(int j=1;j<=n;j++)
a[j]=in.nextInt();
int flag1=1,flag2=1;
long sum=0,maxn=-INF;
for(int j=1,x=1;j<=n;j++)
{
sum+=a[j];
if(sum>maxn)
{
maxn=sum;
flag1=x;
flag2=j;
//System.out.println("j = "+(j-1));
}
if(sum<0)
{
sum=0;
x=j+1;
}
}
System.out.println("Case "+cas+":");
System.out.println(maxn+" "+flag1+" "+flag2+"");
if(cas!=T) System.out.println("");
}
}
}