PAT(甲级)1013. Battle Over Cities (25)

Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

题目大意:给n个城市m 条路 k个询问 然后是m条路 之后是询问,询问是 如果没有城市q1/q2/…./qk 需要建多少条路
分析:并查集 开始以为是并查集删点 自己写着写着发现是删边 先存边 然后不管与qk有关的边 求共有几个连通块 唯一担心会超时 不过n<1000 总数减二 因为总数中包括了要删除的城市 其次 n个连通块 需n-1条路 所以最后ans-2

#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 1010
#define maxm 1000010//数组开小 一个测试点没过
using namespace std;
int n,m,pre[maxn];
struct node{
    int u,v;
}edge[maxm];
void init(){
    for(int i=0;i<=n;++i)
        pre[i]=i;
}
int find_p(int x){
    return x==pre[x]?x:pre[x]=find_p(pre[x]);
}
void join(int a,int b){
    int fa=find_p(a);
    int fb=find_p(b);
    if(fa!=fb)
        pre[fa]=fb;
}
int main()
{
    int k,q,ans;
    bool vis[maxn];
    scanf("%d%d%d",&n,&m,&k);
    for(int i=0;i<m;++i)
        scanf("%d%d",&edge[i].u,&edge[i].v);
    while(k--){
        init();
        scanf("%d",&q);
        for(int i=0;i<m;++i){
            if(edge[i].u!=q&&edge[i].v!=q){
                join(edge[i].u,edge[i].v);
            }
        }
        int ans=0;
        memset(vis,false,sizeof(vis));
        for(int i=1;i<=n;++i){
            int tem=find_p(i);
            if(!vis[tem]){
                vis[tem]=true;
                ans++;
            }
        }
        printf("%d\n",ans-2);
    }
    return 0;
}
内容概要:本文详细介绍了基于FPGA的144输出通道可切换电压源系统的设计与实现,涵盖系统总体架构、FPGA硬件设计、上位机软件设计以及系统集成方案。系统由上位机控制软件(PC端)、FPGA控制核心和高压输出模块(144通道)三部分组成。FPGA硬件设计部分详细描述了Verilog代码实现,包括PWM生成模块、UART通信模块和温度监控模块。硬件设计说明中提及了FPGA选型、PWM生成方式、通信接口、高压输出模块和保护电路的设计要点。上位机软件采用Python编写,实现了设备连接、命令发送、序列控制等功能,并提供了一个图形用户界面(GUI)用于方便的操作和配置。 适合人群:具备一定硬件设计和编程基础的电子工程师、FPGA开发者及科研人员。 使用场景及目标:①适用于需要精确控制多通道电压输出的实验环境或工业应用场景;②帮助用户理解和掌握FPGA在复杂控制系统中的应用,包括PWM控制、UART通信及多通道信号处理;③为研究人员提供一个可扩展的平台,用于测试和验证不同的电压源控制算法和策略。 阅读建议:由于涉及硬件和软件两方面的内容,建议读者先熟悉FPGA基础知识和Verilog语言,同时具备一定的Python编程经验。在阅读过程中,应结合硬件电路图和代码注释,逐步理解系统的各个组成部分及其相互关系。此外,实际动手搭建和调试该系统将有助于加深对整个设计的理解。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值