小型网络中的路由协议,主要有RIP,EIGRP等...
非思科产品不支持EIGRP,所以,如果要实现互联就可以在思科路由器上进行路由再分布_redistribute,可以对RIP协议进行翻译再分布。
EIGRP协议本身的配置还是比较简单的,ps:EIGRP是采用DUAL,OSPF是采用SPT
router eigrp as编号(单区域网络中用同一编号)
network 子网号
其中,Router0只配置RIP协议,Router2只配置EIGRP协议,Router1配置EIGRP,RIP两种协议
配置好以后:
Router0路由表:
C 202.197.96.0/24 is directly connected, FastEthernet0/0
R 202.197.97.0/24 [120/1] via 202.197.98.2, 00:00:18, Serial2/0
C 202.197.98.0/24 is directly connected, Serial2/0
R 202.197.100.0/24 [120/1] via 202.197.98.2, 00:00:18, Serial2/0
Router2路由表:
D 202.197.97.0/24 [90/20514560] via 202.197.100.2, 00:00:19, Serial2/0
D 202.197.98.0/24 [90/21024000] via 202.197.100.2, 00:00:19, Serial2/0
C 202.197.99.0/24 is directly connected, FastEthernet0/0
C 202.197.100.0/24 is directly connected, Serial2/0
Router1路由表:
R 202.197.96.0/24 [120/1] via 202.197.98.1, 00:00:13, Serial2/0
C 202.197.97.0/24 is directly connected, FastEthernet0/0
C 202.197.98.0/24 is directly connected, Serial2/0
D 202.197.99.0/24 [90/20514560] via 202.197.100.1, 00:00:05, Serial3/0
C 202.197.100.0/24 is directly connected, Serial3/0
Router0,Router2中的路由表不识别其他路由更新信息
Router1上重分布:
Router(config)#router rip
Router(config-router)#redistribute eigrp 10 metric 1
Router(config-router)#router eigrp 10
Router(config-router)#redistribute rip metric 10000000 20000 255 1 1500
Router1上路由表:
D EX 202.197.96.0/24 [120/5120256] via 202.197.98.1, 00:00:02, Serial2/0
C 202.197.97.0/24 is directly connected, FastEthernet0/0
C 202.197.98.0/24 is directly connected, Serial2/0
D 202.197.99.0/24 [90/20514560] via 202.197.100.1, 00:12:30, Serial3/0
C 202.197.100.0/24 is directly connected, Serial3/0
其中,第一条的EX表示重分布的路由项。
再次查看路由表:
Router0:
C 202.197.96.0/24 is directly connected, FastEthernet0/0
R 202.197.97.0/24 [120/1] via 202.197.98.2, 00:00:25, Serial2/0
C 202.197.98.0/24 is directly connected, Serial2/0
R 202.197.99.0/24 [120/1] via 202.197.98.2, 00:00:25, Serial2/0
R 202.197.100.0/24 [120/1] via 202.197.98.2, 00:00:25, Serial2/0
Router2:
D EX 202.197.96.0/24 [170/25632000] via 202.197.100.2, 00:00:17, Serial2/0
D 202.197.97.0/24 [90/20514560] via 202.197.100.2, 00:13:44, Serial2/0
D 202.197.98.0/24 [90/21024000] via 202.197.100.2, 00:13:44, Serial2/0
C 202.197.99.0/24 is directly connected, FastEthernet0/0
C 202.197.100.0/24 is directly connected, Serial2/0
这里,可以看出,Router1将接收到的RIP路由通告 转换成EIGRP再分布。
在这里,实际上 为了减少网络中的路由更新,因为RIP为周期更新,因此,可进行被动接口设置
同RIP不同,RIP中的被动接口,不发送更新但是能够接收路由更新
EIGRP中,被动接口 既不发送更新,也不接收更新
因此,在这里Router2使用EIGRP,不设置被动接口,EIGRP由事件触发更新
设置Router0的fa0/0为被动接口
在RIP路由模式下,设置Router1的fa0/0,serial3/0(与Router2相连)为被动接口
在EIGRP路由模式下,设置Router1的serial2/0为被动接口
Router(config)#router rip
Router(config-router)#passive-interface fastethernet0/0
Router(config-router)#passive-interface serial3/0
Router(config)#router eigrp 10
Router(config-router)#passive-interface serial2/0
Router(config-router)#end
Router0将RIP更新发送给Router1,Router1转换成EIGRP更新后,再通告给Router2
Router2将EIGRP更新发送给Router1,Router1转换成RIP更新后,利用serial2/0发送给Router0(RIP)
将不识别的路由更新控制在本地LAN中
运行配置文件:
Router0:
interface FastEthernet0/0
ip address 202.197.96.1 255.255.255.0
duplex auto
speed auto
interface Serial2/0
ip address 202.197.98.1 255.255.255.0
clock rate 64000
router rip
passive-interface FastEthernet0/0
network 202.197.96.0
network 202.197.98.0
Router1:
interface FastEthernet0/0
ip address 202.197.97.1 255.255.255.0
duplex auto
speed auto
interface Serial2/0
ip address 202.197.98.2 255.255.255.0
!
interface Serial3/0
ip address 202.197.100.2 255.255.255.0
router eigrp 10
redistribute rip metric 10000000 20000 255 1 1500
passive-interface Serial2/0
network 202.197.97.0
network 202.197.98.0
network 202.197.100.0
auto-summary
!
router rip
redistribute eigrp 10 metric 1
passive-interface FastEthernet0/0
passive-interface Serial3/0
network 202.197.97.0
network 202.197.98.0
network 202.197.100.0
Router2:
interface FastEthernet0/0
ip address 202.197.99.1 255.255.255.0
duplex auto
speed auto
interface Serial2/0
ip address 202.197.100.1 255.255.255.0
clock rate 64000
router eigrp 10
network 202.197.99.0
network 202.197.100.0
no auto-summary
版权声明:本转自如下
http://ccelily.blogbus.com/logs/40229979.html