NYOJ 427 递推题

本文解决了一道关于递推数列的编程题,通过优化循环和使用记忆化搜索找到数列周期,实现高效计算大规模数值。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

   这道题是昨天月赛的题目,月赛时纠结了1个多小时,今天又纠结了一个多小时,,,悲剧。昨天主要犯的错误时不知道循环可以不从0开始,就这样一直纠结到比赛结束。今天主要纠结在把++j写成了++i,,卧槽,这种错误真TMD的难发现。。。改过后就ac了。题目:

Number Sequence

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
输入
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
输出
For each test case, print the value of f(n) on a single line.
样例输入
1 1 3
1 2 10
0 0 0
样例输出
2
5
ac代码:

 
#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
int f[55],p[7][7];
int main(){
  f[1]=1;f[2]=1;
  int a,b,n;
  while(scanf("%d%d%d",&a,&b,&n),a,b,n){
    memset(p,0,sizeof(p));
	p[1][1]=1;f[1]=1;f[2]=1;
	int i;
	for(i=3;i<=51;++i){
	  f[i]=(a*f[i-1]+b*f[i-2])%7;
	  if(p[f[i-1]][f[i]]==1)
		  break;
	  p[f[i-1]][f[i]]=1;
	}
	int j;
	for(j=1;j<=i-2;++j){
	  if(f[j]==f[i-1]&&f[j+1]==f[i])
		  break;
	}
	if(n<j)printf("%d\n",f[n]);
	else{
	  int k;
	  k=i-1-j;
	  f[0]=f[i-2];
	  n-=(j-1);
	  int xx=n%k;
	  if(xx){printf("%d\n",f[j-1+(n%k)]);}
	  else{printf("%d\n",f[0]);}
	}
  }
  return 0;
}        


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值