Just a Hook (线段树+lazy标记)

上题:

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. 



Now Pudge wants to do some operations on the hook. 

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. 
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: 

For each cupreous stick, the value is 1. 
For each silver stick, the value is 2. 
For each golden stick, the value is 3. 

Pudge wants to know the total value of the hook after performing the operations. 
You may consider the original hook is made up of cupreous sticks. 
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. 
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. 
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 
Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 
Sample Input
1
10
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.
题意 :题意就是屠夫要把他的钩子加长,可选的规格是变成1,2,3,这里要注意 ,是直接变成1,2,3,而不是加上1,2,3,之后就是,他所求的是钩子的全长,所以直接输出sum[1]就好了,注意这是成段更新所以要用到la
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1 
using namespace std;
const int maxn=111111;
int sum[maxn<<2];
int mark[maxn<<2];
void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
	if(mark[rt])//如果有延迟标记 
	{
		mark[rt<<1]=mark[rt<<1|1]=mark[rt];//将当前“状态”传递到他的两个子节点 
		sum[rt<<1]=(m-(m>>1))*mark[rt];//讲状态更新到目标数组 
		sum[rt<<1|1]=(m>>1)*mark[rt];
		mark[rt]=0;
	}
}
void buildtree(int l,int r,int rt)
{
	sum[rt]=1;
	mark[rt]=0;
	if(l==r)
	{
		return ;
	}
	int m=(l+r)>>1;
	buildtree(lson);
	buildtree(rson);
	pushup(rt);
}
void update(int L,int R,int c,int l,int r,int rt)
{
	if(L<=l&&r<=R)
	{
		mark[rt]=c;
		sum[rt]=c*(r-l+1);
		return ;
	}
	pushdown(rt,r-l+1);//要查询的时候 需要更新各种状态 
//	pushdown(rt);
	int m=(l+r)>>1;
	if(L<=m)
	{
		update(L,R,c,lson);
	}
	if(R>m)
	{
		update(L,R,c,rson);
	}
	pushup(rt);
}
int main()
{
	int t;
	int n,te;
	int a,b,c;
	scanf("%d",&t);
	int ca=1;
	while(t--)
	{
		memset(sum,0,sizeof(sum));
		memset(mark,0,sizeof(mark));
		scanf("%d%d",&n,&te);
		buildtree(1,n,1);
		while(te--)
		{
			scanf("%d%d%d",&a,&b,&c);
			update(a,b,c,1,n,1);
		}
		printf("Case %d: The total value of the hook is %d.\n",ca++,sum[1]);
	}
}

zy标记,这个延迟标记是真的很奇妙,,我所理解的延迟标记是:当你所在节点更新之后 ,你不向下更新,而是记录下他下面子节点的状态,当你需要的子节点进行操作的时候你在利用这个“状态”得到叶子节点的信息,这样的话 只有当查询或者更新的时候需要的时候 再向下传递,这样复杂度就会降低好多,讲的不太清楚,看代码吧:
 
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值