HDU 1171 Big Event in HDU【C++练习题】

本文探讨了HDU计算机学院和软件学院设施分配问题,通过动态规划算法寻找最优解,确保两学院所得设施价值最接近且前者不低于后者。示例输入输出及代码实现一并提供。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Big Event in HDU
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54082 Accepted Submission(s): 18312

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1

Sample Output

20 10
40 40

Author

lcy

Recommend

问题简述:
给出每个物体的价值和物体的数量,如何分使得A,B所得价值最接近并且A的价值不能小于B

贴上代码↓↓↓

#include <iostream>
#include <algorithm>
using namespace std;

void main()
{
	int n;
	while (cin >> n && n&&n>=0)
	{
		int t = 0, a, sum = 0;
		int v[10000], dp[200000], num;
		memset(v, 0, sizeof(v));
		memset(dp, 0, sizeof(dp));
		for (int i = 0; i < n; i++)
		{
			cin >> a >> num;
			while (num--)
			{
				v[t++] = a;
				sum += a;
			}
		}
		for (int i = 0; i < t; i++)
		{
			for (int j = sum / 2; j >= v[i]; j--)
			{
				dp[j] = max(dp[j], dp[j - v[i]] + v[i]);
			}
		}
		cout << sum - dp[sum / 2]<<" " << dp[sum / 2] << endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值