描述
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长的滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。
输入
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
输出
输出最长区域的长度。
样例输入
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
样例输出
25
深搜
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAX = 110;
const int step[4][2] = {{0,-1},{-1,0},{0,1},{1,0}};
int r,c,res,d[MAX][MAX],h[MAX][MAX];
int dp(int x,int y){
if(d[x][y] > 0)
return d[x][y];
for(int i = 0;i < 4; ++i){
int nx = x + step[i][0];
int ny = y + step[i][1];
if(nx > 0 && nx < r + 1 && ny > 0 && ny < c + 1 && h[x][y] > h[nx][ny]){
d[x][y] = max(d[x][y],dp(nx,ny) + 1);
}
}
return d[x][y];
}
int main(){
int i,j;
memset(d,0,sizeof(d));
memset(h,-1,sizeof(h));
scanf("%d%d",&r,&c);
for(i = 1;i <= r; ++i){
for(j = 1;j <= c; ++j)
scanf("%d",&h[i][j]);
}
res = 0;
for(i = 1;i <= r; ++i){
for(j = 1;j <= c; ++j){
if(res < dp(i,j))
res = dp(i,j);
}
}
printf("%d\n",res + 1);
return 0;
}
排序后递推
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 110;
int d[4][2] = {{0,-1},{-1,0},{0,1},{1,0}};
int area[MAX][MAX],dp[MAX][MAX];
struct pos{
int x,y,h;
bool operator < (const pos& rhs)const{
return h < rhs.h;
}
};
pos heig[MAX * MAX];
int main(){
int m,n,i,j,cnt,h;
cin >> m >> n;
cnt = 0;
memset(dp,0,sizeof(dp));
for(i = 1;i <= m; ++i){
for(j = 1;j <= n; ++j){
cin >> area[i][j];
heig[cnt].h = area[i][j];
heig[cnt].x = i;
heig[cnt].y = j;
++cnt;
}
}
int res = 0;
sort(heig,heig + cnt);
for(i = 0;i < cnt; ++i){
for(j = 0;j < 4; ++j){
int nx = heig[i].x + d[j][0];
int ny = heig[i].y + d[j][1];
if(nx >= 1 && nx <= m && ny >= 1 && ny <= n){
if(area[nx][ny] > heig[i].h){
dp[nx][ny] = max(dp[nx][ny],dp[heig[i].x][heig[i].y] + 1);
if(dp[nx][ny] > res)
res = dp[nx][ny];
}
}
}
}
// if(res)
// ++res;
cout << res + 1;
return 0;
}