A + B Problem II
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
21 2112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include <iostream>
#include <vector>
#include <string>
using namespace std;
vector<int> add(vector<int>& a1, vector<int>& a2)
{
vector<int> num;
int carry = 0;
for (int i = 0; i < a1.size(); i++)
{
num.push_back((a1[i] + a2[i] + carry) % 10);
if (a1[i] + a2[i] + carry > 9)
carry = (a1[i] + a2[i] + carry) / 10;
else
carry = 0;
}
if (carry > 0)
num.push_back(carry);
return num;
}
int main()
{
//freopen("data.txt", "r", stdin);
vector<int> num1, num2;
string str1, str2;
int N;
cin >> N;
for (int i = 0; i < N; i++) {
cin >> str1 >> str2;
for (int i = str1.length() - 1; i >= 0; i--)
num1.push_back(str1[i] - 48);
for (int i = str2.length() - 1; i >= 0; i--)
num2.push_back(str2[i] - 48);
cout << "Case " << i + 1 << ":" << endl;
cout << str1 << " + " << str2 << " = ";
if (num1.size() > num2.size())
num2.resize(num1.size(), 0);
else if (num2.size() > num1.size())
num1.resize(num2.size(), 0);
num1 = add(num1, num2);
for (int i = num1.size() - 1; i >= 0; i--)
cout << num1[i];
if (i != N - 1)
cout << endl << endl;
else
cout << endl;
num1.clear();
num2.clear();
}
return 0;
}