1044. 火星数字

1044. 火星数字(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

火星人是以13进制计数的:

  • 地球人的0被火星人称为tret。
  • 地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
这里用到了2个格式化函数 sprintf 和sscanf 则个函数很有用 推荐大家掌握  提示: 如果火星文字 高位有数字 则 低位的零不输出。如 130 ->lok
#include <stdio.h>
#include <string.h>
int main()
{
  char str[13][5] = { "","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
  char str1[13][5] = { "tret", "jan", "feb", "mar","apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
  char str2[10], str3[10], str4[10];
  char out[100][10];
  int i, N, Num, Num1, Num2, j = 0;
  scanf("%d", &N);
  getchar();
  while (N--)
  {
    gets(str2);
    if (isalpha(str2[0]) == 0) //  判断是不是数字
    {
      sscanf(str2, "%d", &Num);
      if (Num < 13)
        sprintf(out[j], "%s", str1[Num]);
      else if (Num == 13)
        sprintf(out[j], "tam");
      else  if (Num % 13 == 0)
        sprintf(out[j], "%s", str[(Num - Num % 13) / 13]);
        else
          sprintf(out[j], "%s %s", str[(Num-Num%13) / 13], str1[Num%13]);   //这里先取余再取整  直接除的话 167好像就就不行
    }
    else
    {
      if (strlen(str2) >= 5)                      //字符串大于5就是 2位数了
      {
        sscanf(str2, "%s%s", str3, str4);
        for (i = 0; i < 13; i++)
        {
          if (strcmp(str3, str[i]) == 0)
            Num1 = i;
          if (strcmp(str4, str1[i]) == 0)
            Num2 = i;
        }
        sprintf(out[j], "%d", Num1 * 13 + Num2);   
      }
      else                                         // 一位数
        {
          for (i = 0; i < 13; i++)
          {
            if (strcmp(str2, str1[i]) == 0)
              sprintf(out[j], "%d",i);
            if (strcmp(str2, str[i]) == 0)
              sprintf(out[j], "%d", i*13);
          }
        }
    }
    j++;
  }
  for (i = 0; i < j; i++)
  {
    printf("%s\n", out[i]);                      //输出
  }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值