Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output
6 -1
KMP()算法求next[ ]值的确不好理解,下面的三个连接或许可以帮到你:
http://blog.youkuaiyun.com/ts173383201/article/details/7850120
http://www.cnblogs.com/dolphin0520/archive/2011/08/24/2151846.html
http://www.56.com/u59/v_NjAwMzA0ODA.html这是严老师的一段视频,看完之后豁然开朗。
#include<stdio.h>
#include<string.h>
#define max 1000010
int a[max],b[10010];
int next[10010];
int aLen,bLen;
void get_next()
{
int j,k;
j=0;
k=-1;
next[0]=-1;
while(j<bLen)
{
if(k==-1||b[j]==b[k])
next[++j]=++k;
else
k=next[k];
}
}
void KMP()
{
int i,j=0;
int flag=0;
if(aLen<bLen)
{
printf("-1\n");
return;
}
for(i=0;i<aLen;)//这里i++错误,刚开始思考错了
{
if(a[i]==b[j])
{
if(j==bLen-1)
{
printf("%d\n",i-bLen+2);
flag=1;
break;
}
j++;i++;
}
else
{
j=next[j];
if(j==-1)
{
i++;
j=0;
}
}
}
if(flag==0)
printf("-1\n");
}
int main()
{
int T;
int i,j;
scanf("%d",&T);
while(T--)
{
int k=0;
scanf("%d%d",&aLen,&bLen);
for(i=0; i<aLen; i++)
scanf("%d",&a[i]);
for(j=0; j<bLen; j++)
{
scanf("%d",&b[j]);
}
get_next();
KMP();
}
return 0;
}