Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 101593 Accepted: 31754
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
- Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
- Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题解:n 到k 有三种走法 n-1,n+1, 2*n
特殊情况: 若n=k 返回0
若n>k 只能走n-1
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
const int maxn=100000;
struct point
{
int pos;
int step;
}now,next;
int n,k;
queue<point> Q;
bool vis[maxn];
int bfs()
{
while(!Q.empty()) Q.pop();
now.pos=n;
now.step=0;
vis[now.pos]=true;
Q.push(now);
while(!Q.empty())
{
now=Q.front();
Q.pop();
next=now;
for(int i=0;i<3;i++)
{
if(i==0) next.pos=now.pos+1;
if(i==1) next.pos=now.pos-1;
if(i==2) next.pos=now.pos*2;
next.step=now.step+1;
if(next.pos==k) return next.step;
if(next.pos<0||next.pos>maxn) continue;
if(!vis[next.pos])
{
vis[next.pos]=true;
Q.push(next);
}
}
}
}
int main()
{
while(~(scanf("%d%d",&n,&k)))
{
if(n<k)
cout<<bfs()<<endl;
else if(n==k)
cout<<0<<endl;
else
cout<<n-k<<endl;
}
return 0;
}