POJ - 3278-Catch That Cow(BFS)

本文介绍了一个名为CatchThatCow的问题,讲述了农民约翰如何利用步行和瞬移两种方式在一维数轴上追捕逃跑的奶牛。文章通过示例详细解释了问题背景、输入输出格式,并给出了一种使用广度优先搜索的解决方案。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 101593 Accepted: 31754

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17

Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题解:n 到k 有三种走法 n-1,n+1, 2*n
特殊情况: 若n=k 返回0
若n>k 只能走n-1

#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
const int maxn=100000;
struct point
{
    int pos;
    int step;
}now,next;
 int n,k;
queue<point> Q;
bool vis[maxn];
int bfs()
{
    while(!Q.empty()) Q.pop();

    now.pos=n;
    now.step=0;
    vis[now.pos]=true;
    Q.push(now);
    while(!Q.empty())
    {

        now=Q.front();
        Q.pop();
        next=now;
        for(int i=0;i<3;i++)
        {

            if(i==0) next.pos=now.pos+1;
            if(i==1) next.pos=now.pos-1;
            if(i==2) next.pos=now.pos*2;
            next.step=now.step+1;

            if(next.pos==k) return next.step;
            if(next.pos<0||next.pos>maxn) continue;
            if(!vis[next.pos])
            {

                vis[next.pos]=true;
                Q.push(next);
            }
        }
    }
}
int main()
{
     while(~(scanf("%d%d",&n,&k)))
     {
          if(n<k)
            cout<<bfs()<<endl;
          else if(n==k)
            cout<<0<<endl;
          else
            cout<<n-k<<endl;
     }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值