Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。

Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
整个文件以两个-1结尾。
Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
Sample Output
Yes Yes No
这个题 嘛,我以前虽然做过,但是不怎么理解,就是并查集简单应用,判环和是否联通;
language:c++
code:
#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
struct node
{
int x,y;
node(int a,int b):x(a),y(b) {}
//赋值构造
};
int father[100001],rank[100001]= {0};
void set(int x)
{
father[x]=x;
rank[x]=0;
}
int find(int x);
bool Union(int x,int y)
{
int root1=find(x);
int root2=find(y);
if(root1!=root2)
{
if(rank[root1]<rank[root2])
{
father[root1]=root2;
}
else
{
if(rank[root1]==rank[root2])
{
rank[root1]++;
}
father[root2]=root1;
}
return true;
}
return false;
}
int find(int x)
{
if(father[x]!=x)
father[x]=find(father[x]);
return father[x];
}
int main()
{
//freopen("in.txt","r",stdin);
int u,v;
bool flag=false;
vector<node> vect;
while(scanf("%d%d",&u,&v))
{
if(u==-1&&v==-1)break;
else if((u==0&&v==0))
{
for(size_t i=0; i<vect.size(); i++)
{//判断是否有环
if(Union(vect[i].x,vect[i].y)==false)
{
flag=true;
break;
}
}
int temp=find(vect[0].x);
for(size_t i=0; i<vect.size()&&!flag; i++)
{//判断所有点是否联通
if(find(vect[i].x)!=temp||find(vect[i].y)!=temp)
{
flag=true;
break;
}
}
if(flag==false)printf("Yes\n");
else printf("No\n");
flag=false;
vect.clear();
}
else
{
set(u),set(v);
vect.push_back(node(u,v));
}
}
return 0;
}