Tree of Tree

Tree of Tree

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 37   Accepted Submission(s) : 19
Problem Description
You're given a tree with weights of each node, you need to find the maximum subtree of specified size of this tree.

Tree Definition 
A tree is a connected graph which contains no cycles.

Input

There are several test cases in the input.

The first line of each case are two integers N(1 <= N <= 100), K(1 <= K <= N), where N is the number of nodes of this tree, and K is the subtree's size, followed by a line with N nonnegative integers, where the k-th integer indicates the weight of k-th node. The following N - 1 lines describe the tree, each line are two integers which means there is an edge between these two nodes. All indices above are zero-base and it is guaranteed that the description of the tree is correct.

Output

One line with a single integer for each case, which is the total weights of the maximum subtree.

Sample Input

3 1
10 20 30
0 1
0 2
3 2
10 20 30
0 1
0 2

Sample Output

30
40
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<iostream>
#include<iterator>
#include<vector>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<map>
#include<algorithm>
using namespace std;
#define LL long long
#define inf 1<<29
int k;
vector<int>v[110];
int dp[110][110];
int vis[110];
void DFS(int x)
{
    vis[x]=1;
    for(int i=0;i<v[x].size();i++)
    {
        int d=v[x][i];
        if(!vis[d])
        {
            DFS(d);
            for(int j=k;j>=1;j--)
            {
                for(int r=1;r<=j;r++)
                {
                    dp[x][j]=max(dp[x][r]+dp[d][j-r],dp[x][j]);
                }
            }
        }
    }
}
int main()
{
    int n;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        for(int i=0;i<=100;i++)
        {
            vis[i]=0; v[i].clear();
        }
        memset(dp,0,sizeof(dp));
        int a,b;
        for(int i=0;i<n;i++)
            scanf("%d",&dp[i][1]);
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d",&a,&b);
            v[a].push_back(b);
            v[b].push_back(a);
        }
        DFS(0);
        int ans=0;
        for(int i=0;i<n;i++)
        {
            ans=max(ans,dp[i][k]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值