HDU 2602---Bone Collector【01背包】

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29057    Accepted Submission(s): 11869


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
简单的 01背包问题。。
问题分析:一个人拿着体积固定的包收集骨头(人的骨头也要。。。禽兽),每块骨头的价值和体积不同,问:在体积允许的 范围内,能收集骨头的最大价值是多少。
第一行输入案例的个数。第二行分别输入骨头的数量和包的体积。第三行输入每块骨头的价值。第四行输入对应的 体积。
代码奉上:
一维数组
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int f[2090],w[2090],c[2090],m,n,i,j;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
        scanf("%d",&w[i]);
        for(i=0;i<n;i++)
        scanf("%d",&c[i]);
        memset(f,0,sizeof(f));
        for(i=0;i<n;i++)
        for(j=m;j>=c[i];j--)
        {
            f[j]=max(f[j],f[j-c[i]]+w[i]);
        }
        printf("%d\n",f[m]);
    }
    return 0;
}

二维数组
#include<stdio.h>
#include<string.h>
int f[1001][1001],m,n,i,j,y,w[1001],c[1001];
int main()
{

    scanf("%d",&y);
    while(y--)
    {
        scanf("%d%d",&m,&n);
        for(i=1;i<=m;i++)
        scanf("%d",&w[i]);
        for(i=1;i<=m;i++)
        scanf("%d",&c[i]);
        memset(f,0,sizeof(f));
        for(i=1;i<=m;i++)
        for(j=0;j<=n;j++)
        {
            if((j-c[i])>=0&&f[i-1][j]<f[i-1][j-c[i]]+w[i])
            f[i][j]=f[i-1][j-c[i]]+w[i];
            else f[i][j]=f[i-1][j];
        }
        printf("%d\n",f[m][n]);
    }
    return 0;

}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值