练习题目总结 Reversing Linked List(C++)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

本程序目前仍有不足,改日再改hh
主要解决有多余结点不在链表上问题。

#include<iostream>
#include<iomanip>
using namespace std;
typedef struct node* List;
typedef struct node{
    int address;
    int num;
    int next;
};

List find(int a,List head){
    
    return NULL;
}

void ex(node &a,node &b){
    node temp;
    temp.address=a.address;
    temp.next=a.next;
    temp.num=a.num;
    a.address=b.address;
    a.next=b.next;
    a.num=b.num;
    b.address=temp.address;
    b.next=temp.next;
    b.num=temp.num;
}

List Regular(List LinkedList,int first,int n){
    for(int temp=0;temp<n;temp++){
        //cout<<LinkedList[temp].address<<endl;
        if(LinkedList[temp].address==first){
            ex(LinkedList[0],LinkedList[temp]);
            break;
        }
    }
    int current=0;
    while(current<n){
        if(n<=1){
            break;
        }
        for(int temp=1;temp<n;temp++){
            if(LinkedList[current].next==-1){
                current=n;
                break;
            }
            //cout<<LinkedList[current].next<<" "<<LinkedList[temp].address<<endl; 
            if(LinkedList[current].next==LinkedList[temp].address){                             
                current++;
                if(current!=temp){
                    ex(LinkedList[current],LinkedList[temp]);
                }
            }            
        }
    }
    return LinkedList;
}
List Reverse(List LinkedList,int n,int x){
    int repeat=n/x;
    int times=0;
    for(times=0;times<repeat;times++){
        for(int temp=1;temp<=x;temp++){
            int index=(times+1)*x-temp;
            if(index%x!=0){
                LinkedList[index].next=LinkedList[index-1].address;
            }else{
                if((times+1)*x>=n){
                    LinkedList[index].next=-1;
                }else
                    LinkedList[index].next=LinkedList[(times+1)*x].address;
            }
        }
            cout<<setfill('0') << setw(5)<<LinkedList[index].address;
            cout<<" "<<LinkedList[index].num<<" ";
            if(LinkedList[index].next!=-1){
            cout<<setfill('0')<<setw(5)<<LinkedList[index].next<<endl;
        }else
        {
            cout<<"-1";
        }        
        }
    }
    for(int temp=x*repeat;temp<n;temp++){
        cout<<setfill('0')<<setw(5)<<LinkedList[temp].address;
        cout<<" "<<LinkedList[temp].num<<" ";
        if(LinkedList[temp].next!=-1){
            cout<<setfill('0')<<setw(5)<<LinkedList[temp].next<<endl;
        }else
        {
            cout<<"-1";
        }
        
    }   
}


void Print(List A,int n){
    for(int temp=0;temp<n;temp++){
        cout<<A[temp].address<<" "<<A[temp].num<<" "<<A[temp].next<<endl;
    }
}

int main(void){
    int first_address,n,x;

    cin>>first_address>>n>>x;
    List LinkedList=new node[n];

    for(int temp=0;temp<n;temp++){
        int address,num,next;
        cin>>address>>num>>next;
        LinkedList[temp].address=address;
        LinkedList[temp].num=num;
        LinkedList[temp].next=next;
    }
    
    LinkedList=Regular(LinkedList,first_address,n);

    LinkedList=Reverse(LinkedList,n,x);

    return 0;
}
### C++ 实现检查输入链表是否为回文 为了实现一个时间复杂度为 \( O(n) \),额外空间复杂度为 \( O(1) \) 的算法来判断链表是否为回文结构,可以采用以下策略: #### 方法概述 1. 使用快慢指针找到链表的中间位置。 2. 将链表的后半部分反转。 3. 对比前半部分和反转后的后半部分是否相同。 4. 如果需要保持原始链表不变,则可以在最后恢复链表。 以下是完整的 C++ 实现代码: ```cpp /** * Definition for singly-linked list. * struct ListNode { * int val; * ListNode *next; * ListNode(int x) : val(x), next(nullptr) {} * }; */ class Solution { public: bool isPalindrome(ListNode* head) { if (head == nullptr || head->next == nullptr) return true; // Step 1: Find the middle of the linked list using slow and fast pointers ListNode *slow = head, *fast = head; while (fast && fast->next) { slow = slow->next; fast = fast->next->next; } // Step 2: Reverse the second half of the linked list ListNode *prev = nullptr, *curr = slow, *nextNode = nullptr; while (curr) { nextNode = curr->next; curr->next = prev; prev = curr; curr = nextNode; } // Step 3: Compare the first half with the reversed second half ListNode *left = head, *right = prev; while (right) { if (left->val != right->val) return false; left = left->next; right = right->next; } // Optional: Restore the original list by reversing back the second half /* curr = prev; prev = nullptr; while (curr) { nextNode = curr->next; curr->next = prev; prev = curr; curr = nextNode; } */ return true; } }; ``` #### 关键点解析 - **快慢指针找中点**:通过快慢指针定位到链表的中间节点。当 `fast` 到达链表末尾时,`slow` 正好位于中间[^1]。 - **反转链表**:利用三指针法(`prev`, `curr`, `nextNode`),将链表的一部分进行原地反转[^2]。 - **对比前后两部分**:逐一比较链表的前半部分和反转后的后半部分,如果发现不匹配则返回 `false`[^3]。 - **可选操作**:如果希望保留原始链表结构,在完成判断后需再次反转链表的后半部分以还原数据。 #### 示例测试 假设有一个链表如下: ```plaintext Input: 1 -> 2 -> 3 -> 2 -> 1 Output: true ``` 执行上述代码会返回 `true`,因为它是回文链表。 另一个例子: ```plaintext Input: 1 -> 2 -> 3 -> 4 -> 5 Output: false ``` 由于它不是回文结构,因此返回 `false`。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值