POJ 2965 The Pilots Brothers' refrigerator(dfs+记录路径)

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18634 Accepted: 7141 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

题意:
给你一个4*4的矩阵,矩阵由‘+’或‘-’组成,现在你可以对矩阵任意一个位置进行翻转操作,然后该位置的行和列也会同样翻转,问至少翻转多少次可以讲所有的位置都变为‘-’,并输出所有的操作

题解;
因为显然每个位置至多翻转一次,所以所有的可能一共有2^16中,那么DFS枚举所有情况就好了,同时注意记录每一次的操作,左后一次输出。

题目链接:http://poj.org/problem?id=2965

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<set>
#define stop system("pause")
#define err cout<<"******"<<endl;
#define inf 0x7fffffff
using namespace std;
const int N = 1010;

bool handle[5][5];//用来存储输入的矩阵,操作方便
int vis[50];//路径的临时存放数组
int way[50];//答案路径,将坐标化为一维存储
int ans;//答案
int I;

bool check(){//检查是否全为‘-’
    for(int i=0;i<4;i++){
        for(int j=0;j<4;j++){
            if(handle[i][j]!=false) return false;
        }
    }
    return true;
}

void filp(int x,int y){//翻转操作
    handle[x][y]=!handle[x][y];
    for(int i=0;i<4;i++){
        handle[x][i]=!handle[x][i];
        handle[i][y]=!handle[i][y];
    }
}

void dfs(int x,int y,int cnt,int k){
    if(check()){
        if(ans>cnt){
            for(int i=0;i<k;i++){
                way[i]=vis[i];
            }
            I=k;
            ans=cnt;
        }
        return;
    }
    if(x==3&&y==4) return ;
    filp(x,y);
    if(x!=3&&y==3){
        vis[k++]=x;
        vis[k++]=y;
        dfs(x+1,0,cnt+1,k);
    }
    else {
        vis[k++]=x;
        vis[k++]=y;
        dfs(x,y+1,cnt+1,k);
    }
    filp(x,y);
    k=k-2;
    if(x!=3&&y==3) dfs(x+1,0,cnt,k);
    else dfs(x,y+1,cnt,k);
}

int main(){
    for(int i=0;i<4;i++){
        for(int j=0;j<4;j++){
            char ch;
            scanf("%c",&ch);
            if(ch=='+') handle[i][j]=true;
            else handle[i][j]=false;
        }
        getchar();
    }
    ans=inf;
    dfs(0,0,0,0);
    if(ans==inf) printf("Impossible\n");
    else {
        printf("%d\n",ans);
        for(int i=0;i<I;i++){
            if(i&1) printf("%d\n",way[i]+1);
            else printf("%d ",way[i]+1);
        }
    }
    return 0;
}



基于python实现的粒子群的VRP(车辆配送路径规划)问题建模求解+源码+项目文档+算法解析,适合毕业设计、课程设计、项目开发。项目源码已经过严格测试,可以放心参考并在此基础上延申使用,详情见md文档 算法设计的关键在于如何向表现较好的个体学习,标准粒子群算法引入惯性因子w、自我认知因子c1、社会认知因子c2分别作为自身、当代最优解和历史最优解的权重,指导粒子速度和位置的更新,这在求解函数极值问题时比较容易实现,而在VRP问题上,速度位置的更新则难以直接采用加权的方式进行,一个常见的方法是采用基于遗传算法交叉算子的混合型粒子群算法进行求解,这里采用顺序交叉算子,对惯性因子w、自我认知因子c1、社会认知因子c2则以w/(w+c1+c2),c1/(w+c1+c2),c2/(w+c1+c2)的概率接受粒子本身、当前最优解、全局最优解交叉的父代之一(即按概率选择其中一个作为父代,不加权)。 算法设计的关键在于如何向表现较好的个体学习,标准粒子群算法引入惯性因子w、自我认知因子c1、社会认知因子c2分别作为自身、当代最优解和历史最优解的权重,指导粒子速度和位置的更新,这在求解函数极值问题时比较容易实现,而在VRP问题上,速度位置的更新则难以直接采用加权的方式进行,一个常见的方法是采用基于遗传算法交叉算子的混合型粒子群算法进行求解,这里采用顺序交叉算子,对惯性因子w、自我认知因子c1、社会认知因子c2则以w/(w+c1+c2),c1/(w+c1+c2),c2/(w+c1+c2)的概率接受粒子本身、当前最优解、全局最优解交叉的父代之一(即按概率选择其中一个作为父代,不加权)。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值