TOYS
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 10668 | Accepted: 5130 |
Description
Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0 3 1 4 3 6 8 10 10 15 30 1 5 2 1 2 8 5 5 40 10 7 9 4 10 0 10 100 0 20 20 40 40 60 60 80 80 5 10 15 10 25 10 35 10 45 10 55 10 65 10 75 10 85 10 95 10 0
Sample Output
0: 2 1: 1 2: 1 3: 1 4: 0 5: 1 0: 2 1: 2 2: 2 3: 2 4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are "in" the box.
题目链接: http://poj.org/problem?id=2318
简单的点与直线之间的关系
方法一:
先求出每天直线的方程,在从左向右比较
代码:
方法二:
利用叉积判断点与直线的关系
叉积的详细讲解文章: http://blog.youkuaiyun.com/u013557725/article/details/40146311
代码:
题目链接: http://poj.org/problem?id=2318
简单的点与直线之间的关系
方法一:
先求出每天直线的方程,在从左向右比较
代码:
<pre name="code" class="cpp">/**********
Problem: 2318 User: pluto227
Memory: 316K Time: 532MS
Language: C++ Result: Accepted
**********/
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#define DEBUGMODE
#define eps 1e-6
#define LL long long
using namespace std;
const int N = 5000+100;
int num[N];
struct node {
double x1,x2;
double k,b;
} line[N];
int cmp(node x,node y) {
return x.x1<y.x1;
}
int main() {
int n,m;
double x1,y1,x2,y2;
int jud=1;
while(~scanf("%d",&n),n) {
if(jud==0) puts("");
scanf("%d %lf %lf %lf %lf",&m,&x1,&y1,&x2,&y2);
for(int i=0; i<n; i++) {
scanf("%lf %lf",&line[i].x1,&line[i].x2);
if(line[i].x1==line[i].x2) {
line[i].k=0,line[i].b=0;
continue;
}
line[i].k=(y1-y2)/(line[i].x1-line[i].x2);
line[i].b=y1-line[i].x1*line[i].k;
}
line[n].k=line[n].b=0;
line[n].x1=line[n].x2=x2;
memset(num,0,sizeof(num));
double x,y;
for(int i=0; i<m; i++) {
scanf("%lf %lf",&x,&y);
for(int j=0; j<=n; j++) {
if(fabs(line[j].k-0)<eps) {
if(x<line[j].x1) {
num[j]++;
break;
}
} else if(line[j].k-0>eps) {
if(y>line[j].k*x+line[j].b) {
num[j]++;
break;
}
} else if(line[j].k<0) {
if(y<line[j].k*x+line[j].b) {
num[j]++;
break;
}
}
}
}
jud=0;
for(int i=0; i<=n; i++) {
printf("%d: %d\n",i,num[i]);
}
}
return 0;
}
方法二:
利用叉积判断点与直线的关系
叉积的详细讲解文章: http://blog.youkuaiyun.com/u013557725/article/details/40146311
代码:
/***********
Problem: 2318 User: pluto227
Memory: 316K Time: 125MS
Language: C++ Result: Accepted
***********/
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#define DEBUGMODE
#define EPS 1e-6
#define LL long long
using namespace std;
const int N = 5000+10;
int sum[N];
struct point {
double x;
double y;
};
struct Line {
point a;
point b;
} line[N];
double multi(point p0,point p1,point p2) {
return (p0.x-p1.x)*(p2.y-p1.y)-(p2.x-p1.x)*(p0.y-p1.y);
}
void B_search(point p,int n) {
int l=0,r=n-1;
int mid;
while(l<r) {
mid=(l+r)>>1;
if(multi(p,line[mid].b,line[mid].a)>0) l=mid+1;
else r=mid;
}
if(multi(p,line[l].b,line[l].a)>0) sum[l+1]++;
else sum[l]++;
}
int main() {
int n,m;
double x1,y1,x2,y2;
int jud=1;
while(~scanf("%d",&n)&&n) {
memset(sum,0,sizeof(sum));
if(jud==0) puts("");
scanf("%d %lf %lf %lf %lf",&m,&x1,&y1,&x2,&y2);
for(int i=0; i<n; i++) {
double p_x1,p_x2;
scanf("%lf %lf",&p_x1,&p_x2);
line[i].a.x=p_x1;
line[i].a.y=y1;
line[i].b.x=p_x2;
line[i].b.y=y2;
}
for(int i=0; i<m; i++) {
double x,y;
scanf("%lf %lf",&x,&y);
point p;
p.x=x;
p.y=y;
B_search(p,n);
}
jud=0;
for(int i=0; i<=n; i++) {
printf("%d: %d\n",i,sum[i]);
}
}
return 0;
}