Has the sum exceeded
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3218 Accepted Submission(s): 683
Problem Description
As we all know, in the computer science, an integer A is in the range of 32-signed integer, which means the integer A is between -2^31 and (2^31)-1 (inclusive), and A is a 64-signed integer, which means A is between -2^63 and (2^63)-1(inclusive). Now we give the K-signed range, and two K-signed integers A and B, you should check whether the sum of A and B is beyond the range of K-signed integer or not.
Input
There will be many cases to calculate. In each case, there comes the integer K (2<=K<=64) first in a single line. Then following the line, there is another single line which has two K-signed integers A and B.
Output
For each case, you should estimate whether the sum is beyond the range. If exceeded, print “Yes”, otherwise “WaHaHa”.
Sample Input
32 100 100
Sample Output
WaHaHa
主要思路是把数转化为二进制判断
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
__int64 a[70];
int main()
{
__int64 c,d;
int num,k,i,j,flag;
while(scanf("%d",&k)!=EOF)
{
flag=0;
scanf("%I64d%I64d",&c,&d);
num=0;
memset(a,0,sizeof(a));
if((c<0&&d>0)||(c>0&&d<0))
{
printf("WaHaHa\n");
continue;
}
if(c<0&&d<0)
{
c=-c;
d=-d;
flag=1;
}
while(c!=0)
{
a[num++]=c%2;
c=c/2;
}
num=0;
while(d!=0)
{
a[num]=a[num]+d%2;
num++;
d=d/2;
}
for(i=0;i<68;i++)
{
a[i+1]=a[i+1]+a[i]/2;
a[i]=a[i]%2;
}
for(i=68; i>=0; i--)
if(a[i]!=0)
break;
if(i==k-1&&flag==1)
{
for(j=i-1;j>=0;j--)
{
if(a[j]!=0)
break;
}
}
if(i<k-1)
printf("WaHaHa\n");
else
if(i==k-1&&flag==1&&j<0)
{
printf("WaHaHa\n");
}
else
printf("Yes\n");
}
return 0;
}