hdu 2037 今年暑假不AC

今年暑假不AC

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26760    Accepted Submission(s): 14085


Problem Description
“今年暑假不AC?”
“是的。”
“那你干什么呢?”
“看世界杯呀,笨蛋!”
“@#$%^&*%...”

确实如此,世界杯来了,球迷的节日也来了,估计很多ACMer也会抛开电脑,奔向电视了。
作为球迷,一定想看尽量多的完整的比赛,当然,作为新时代的好青年,你一定还会看一些其它的节目,比如新闻联播(永远不要忘记关心国家大事)、非常6+7、超级女生,以及王小丫的《开心辞典》等等,假设你已经知道了所有你喜欢看的电视节目的转播时间表,你会合理安排吗?(目标是能看尽量多的完整节目)
 

Input
输入数据包含多个测试实例,每个测试实例的第一行只有一个整数n(n<=100),表示你喜欢看的节目的总数,然后是n行数据,每行包括两个数据Ti_s,Ti_e (1<=i<=n),分别表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。n=0表示输入结束,不做处理。
 

Output
对于每个测试实例,输出能完整看到的电视节目的个数,每个测试实例的输出占一行。
 

Sample Input
  
  
12 1 3 3 4 0 7 3 8 15 19 15 20 10 15 8 18 6 12 5 10 4 14 2 9 0
 

Sample Output
  
  
5
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1050  1009  1051  1052  1789 

实际上就是选择不相交区间,先按右端点进行排序,再分别去掉包含的区间和相交的区间,这里区间的选择采用的是贪心的策略,模板题啊啊。

O(n2)做法

#include<iostream>
#include<cstdio>
#include<algorithm>
typedef long long LL;
using namespace std;
struct d
{
    int l,r,ok;
    d()
    {
        ok=1;
    }
    bool operator <(const d&a)const
    {
        return r<a.r;
    }
};
int main()
{
    int N;
    while(cin>>N&&N)
    {
        d A[N+1];
        int l,r;
        for(int i=1; i<=N; i++)
        {
            cin>>l>>r;
            A[i].r=max(l,r);
            A[i].l=min(l,r);
        }
        sort(A+1,A+1+N);
        int ans=0;
        for(int i=1; i<=N; i++)if(A[i].ok)
            {
                ans++;
                for(int j=i+1; j<=N; j++)if(A[j].l<A[i].r)A[j].ok=0;
            }
        cout<<ans<<endl;
    }
    return 0;
}


O(n)做法


#include<iostream>
#include<cstdio>
#include<algorithm>
typedef long long LL;
using namespace std;
struct d
{
    int l,r,ok;
    bool operator <(const d&a)const
    {
        return r<a.r;
    }
};
int main()
{
    int N;
    while(cin>>N&&N)
    {
        d A[N+1];
        int l,r;
        for(int i=1; i<=N; i++)
        {
            cin>>l>>r;
            A[i].r=max(l,r);
            A[i].l=min(l,r);
        }
        sort(A+1,A+1+N);
        int ans=0,M=-10;
        for(int i=1; i<=N; i++)if(A[i].l>=M)
        {
                ans++;
                M=A[i].r;
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值