RGCDQ
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 483 Accepted Submission(s): 235
Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know
maxGCD(F(i),F(j))
(L≤i<j≤R)
Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.
All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
In the next T lines, each line contains L, R which is mentioned above.
All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
Output
For each query,output the answer in a single line.
See the sample for more details.
See the sample for more details.
Sample Input
2 2 3 3 5
Sample Output
1 1
Source
#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
int T;
int l,r;
const int maxn = 1000010;
int a[maxn];
int dp[maxn][8];
int c[maxn];
void init()
{
memset(a,0,sizeof(a));
for(int i=2;i<=1000000;i++)
{
if(a[i] == 0)
{
for(int j=i;j<=1000000;j+=i)
{
a[j]++;
}
}
}
memset(dp,0,sizeof(dp));
for(int i=2;i<=1000000;i++)
{
for(int j=1;j<=7;j++)
{
if(a[i] == j) dp[i][j] = dp[i-1][j] + 1;
else dp[i][j] = dp[i-1][j];
}
}
}
int main()
{
freopen("1.txt","r",stdin);
init();
memset(c,0,sizeof(c));
scanf("%d",&T);
while(T --)
{
scanf("%d%d",&l,&r);
for(int j=1;j<=7;j++)
c[j] = dp[r][j] - dp[l-1][j];
int ans = 1;
for(int i=1;i<=7;i++)
{
if(c[i] >= 2) ans = i;
}
if (c[6]>=1&&c[3]>=1) ans=max(ans,3);
if (c[6]>=1&&c[2]>=1) ans=max(ans,2);
if (c[4]>=1&&c[2]>=1) ans=max(ans,2);
if (c[6]>=1&&c[4]>=1) ans=max(ans,2);
printf("%d\n",ans);
}
}