Billboard+hud+线段树单点更新

本文介绍了一个简单的单点更新算法,用于解决公告如何在限定尺寸的矩形公告板上布局的问题。该算法通过记录并更新每个区间的剩余宽度来确定公告的最佳放置位置,当无法放置时输出-1。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10965    Accepted Submission(s): 4865


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
解决方案:很简单的一道单点更新,只要在更新的时候随便搞搞。用一个数组记录每个区间的剩余宽度,贴广告时可根据每个区间的剩余宽度选择哪个位置贴,并更新该位置的剩余宽度,若找不到相应的位置输出-1。
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX 1200003
using namespace std;
int width[4*MMAX];
int n,h,w;
void build(int rt,int L,int R)
{

    if(L==R)
    {
        width[rt]=w;
    }
    else
    {
        int M=(L+R)/2;
        build(rt*2,L,M);
        build(rt*2+1,M+1,R);
        width[rt]=max(width[rt*2],width[rt*2+1]);
    }
}
void update(int rt,int L,int R,int W)
{

    int l=rt*2,r=rt*2+1;
    int M=(L+R)/2;
    if(L==R)
    {
        if(width[rt]<W)
        {
            printf("-1\n");
            return ;
        }
        width[rt]-=W;
        printf("%d\n",L);
        return ;
    }
    if(W<=width[l])
    {
        update(l,L,M,W);
    }
    else if(W<=width[r])
    {
        update(r,M+1,R,W);
    }
    else
    {
        printf("-1\n");
        return ;
    }
    width[rt]=max(width[l],width[r]);

}
int main()
{
    while(~scanf("%d%d%d",&h,&w,&n))
    {
        int N=min(h,n);
        build(1,1,N);
        for(int i=0; i<n; i++)
        {
            int a;
            scanf("%d",&a);
            update(1,1,N,a);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值