Corn Fields +POJ+dp+状态压缩

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7056 Accepted: 3754

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.
解决方案:每一行的种法和上一行有关, dp[i][j]=(dp[i][j]+dp[i-1][k]),i代表第几行,j代表状态的编号,每一行的种法和上一行的状态有关,由于每一行的最多只有12个,所以可用一个二进制数来存,具体做法见代码。最后求最后一行的总状态就行了。做这题要灵活运用数字的位运算。

code:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1<<13;
int M,N,top;
int state[maxn];///每行能种的状态
int cur[maxn];///土地每行的状态
int dp[14][maxn];///每行的状态
void init()
{

    int s=1<<N;
    top=0;

    for(int i=0; i<s; i++)
    {
        if(!(i&(i<<1))) state[++top]=i;

    }

}
int main()
{
    while(~scanf("%d%d",&M,&N))
    {
        init();///求出行内符合的状态
        for(int i=1; i<=M; i++)
        {
            cur[i]=0;
            for(int j=1; j<=N; j++)
            {
                int num;
                scanf("%d",&num);
                if(num==0)
                {
                    cur[i]+=1<<(N-j);///能种的位置标1,不能种的是0
                }
            }
        }
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=top; i++)
        {
            if(!(state[i]&cur[1]))
                dp[1][i]=1;///初始化第一行
        }
        for(int i=2; i<=M; i++)
            for(int j=1; j<=top; j++)
            {
                if(!(state[j]&cur[i]))
                {
                    for(int k=1; k<=top; k++)
                    {
                        if(!(state[j]&state[k]))
                        {
                            if(!(cur[i-1]&state[k]))
                            {
                                dp[i][j]=(dp[i][j]+dp[i-1][k])%100000000;
                            }
                        }
                    }
                }
            }
        int ans=0;

        for(int j=1; j<=top; j++)
        {
            ans=(ans+dp[M][j])%100000000;
        }

        printf("%d\n",ans);

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值