【二分图|最大匹配】POJ-1469 COURSES

本文介绍了一个关于学生与课程匹配的问题,通过构建特定的图模型来判断是否能从N个学生中选出P个不同课程的代表。使用C++实现了一种有效的匹配算法。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

COURSES
Time Limit: 1000MS Memory Limit: 10000K
   

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO
————————————————————疲れた分割線————————————————————
思路:水题没什么好说的。。要多多练习盲打和Vim!
P.S. 顺便说一句,在这样的二部图中,因为是单向边,所以就算X部和Y部共用点都是没问题的,可以节省空间。
代码如下:
/*
ID: j.sure.1
PROG:
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <climits>
#include <iostream>
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
/****************************************/
const int N = 444, M = 33333;
struct Edge {
	int v, next;
	Edge(){}
	Edge(int _v, int _next):
		v(_v), next(_next){}
}edge[M];
int tot, head[N], mac[N], n, m;
bool vis[N];

void init()
{
	tot = 0;
	memset(head, -1, sizeof(head));
}

void add(int u, int v)
{
	edge[tot] = Edge(v, head[u]); head[u] = tot++;
}

bool dfs(int u)
{
	for(int i = head[u]; ~i; i = edge[i].next) {
		int v = edge[i].v;
		if(!vis[v]) {
			vis[v] = true;
			if(mac[v] == -1 || dfs(mac[v]))
			{
				mac[v] = u;
				return true;
			}
		}
	}
	return false;
}

int match()
{
	int ret = 0;
	memset(mac, -1, sizeof(mac));
	for(int i = 1; i <= m; i++) {
		memset(vis, 0, sizeof(vis));
		if(dfs(i)) {
			ret++;
		}
	}
	return ret;
}

int main()
{
#ifdef J_Sure
//	freopen("000.in", "r", stdin);
//	freopen(".out", "w", stdout);
#endif
	int Cas;
	scanf("%d", &Cas);
	while(Cas--) {
		init();
		scanf("%d%d", &m, &n);
		int p;
		for(int i = 1; i <= m; i++) {
			scanf("%d", &p);
			int x;
			while(p--) {
				scanf("%d", &x);
				add(i, x);//X部、Y部共用点
			}
		}
		int ans = match();
		printf("%s\n", ans < m ? "NO" : "YES");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值