Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 37941 Accepted Submission(s): 14292
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2 3 4
Sample Output
7 6HintIn the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
Author
Ignatius.L
#include<iostream>
using namespace std;
int quick_mod(int a, int b, int n){
if(b==1) return a;
int x = quick_mod(a, b/2, n);
long long ans;
ans = (long long)x*x%n;
if(b&1){
ans = (long long)ans*a%n;
}
return (int)ans;
}
int main(){
int N;
scanf("%d", &N);
int n;
while(N--){
scanf("%d", &n);
cout<<quick_mod(n, n, 10)<<endl;
}
return 0;
}