zoj_2724 Windows Message Queue

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
 
分析:
    本题是模拟Windows处理消息,优先级高的消息先被处理。通过本题学到一个新的容器——优先队列priority_queue
    优先队列与队列一样,只从队尾插入元素,从队首删除元素。但它有一个特性,就是队列中的最大元素总是位于队首,所以出队时,并非按照先进先出的原则,而是将队列中当前最大的元素出队。元素的比较规则默认是从大到小排序,也可以重载操作符“<”来重新定义比较规则。
    PS:重载“<”为从大到小排列;重载“( )”,由小到大排列采用“>”,由大到小排列采用“<”
    还有一点就是解决超时问题,因为数据量大,多达60 000行字符串。所以必须采用scanf和printf输入输出
 
答案:
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;
struct Message{
    char Name[100];
    int Data;
    int Priority;
    //重载操作符,自定义排序规则
    bool operator < (const Message &a) const
    {
        return a.Priority<Priority;
    }
};
priority_queue<Message> v; //需引入<queue>
int main()
{
    char command[100];
    Message message;
    while(scanf("%s",command)!=EOF)
    {
        if(strcmp(command,"GET")==0)
        {
            //队列为空
            if(v.size()==0)
            printf("EMPTY QUEUE!\n");
            else
            {
                printf("%s %d\n",v.top().Name,v.top().Data);
                v.pop();//出队列操作,即清除当前消息
            }
        }
        else if(strcmp(command,"PUT")==0)
        {
            scanf("%s%d%d",&message.Name,&message.Data,&message.Priority);
            v.push(message);//入队列操作
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值