Maximum Sequence
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1887 Accepted Submission(s): 671
Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.
Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: a
n+1
…a
2n![]()
. Just like always, there are some restrictions on
a
n+1
…a
2n![]()
: for each number
a
i![]()
, you must choose a number
b
k![]()
from {bi}, and it must satisfy
a
i![]()
≤max{
a
j![]()
-j│
b
k![]()
≤j<i}, and any
b
k![]()
can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{
∑
2n
n+1
a
i![]()
} modulo
10
9![]()
+7 .
Now Steph finds it too hard to solve the problem, please help him.
Given two integer sequences {ai} and {bi} with the same length n, you are to find the next n numbers of {ai}: a
Now Steph finds it too hard to solve the problem, please help him.
Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
Output
For each test case, print the answer on one line: max{
∑
2n
n+1
a
i![]()
} modulo
10
9![]()
+7。
Sample Input
4 8 11 8 5 3 1 4 2
Sample Output
27HintFor the first sample: 1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9; 2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;
这道题大致意思可以理解为去求一串数列ai。。。an中的最大值的和(1<=i<=n),关键点就在于不可能每次去寻找都要遍历一遍,仔细想想就会明白在这样的规则下存在:max1>=max2>=max3>=.....>=maxn,maxi代表从i开始到an的最大值。
#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
const int MOD=1e9+7;
int a[250005],b[250005],n[250005];
int main()
{
int m;
while(scanf("%d",&m)!=EOF)
{
int i;
for(i=1;i<=m;i++)
{
scanf("%d",&a[i]);
a[i]-=i;
}
for(i=1;i<=m;i++)
{
scanf("%d",&b[i]);
}
sort(b+1,b+1+m);
n[m]=a[m];
for(i=m-1;i>=1;i--)
{
if(a[i]>n[i+1])
{
n[i]=a[i];
}
else n[i]=n[i+1];
}
long long int c=n[b[1]];
long long int d=c-m-1;
long long int sum=0;
sum=(sum+c)%MOD;
for(i=2;i<=m;i++)
{
c=n[b[i]];
c=max(c,d);
sum=(sum+c)%MOD;
}
cout<<sum%MOD<<endl;
}
return 0;
}